Fusion 110cc fuses blown repeatedly - ATVConnection.com ATV Enthusiast Community



Reply
 
Thread Tools Search this Thread
  #1  
Old 08-27-2016, 02:30 PM
Weekend Warrior
Thread Starter
 
Join Date: Aug 2016
Posts: 12
Default Fusion 110cc fuses blown repeatedly

I am sorry if this has be solved before, i can not find it anywhere if that's the case. So i have a pretty much new 110cc Chinese i haven't had any issues really with it since i got it. the other day it all of a sudden wouldn't start. i Looked around and i ended up finding the fuse that is connected to the + side of the battery had blown. The fuse does not say its ampage so it was a small guess kinda, it blew a 2Amp instantly and a 15 Amp after about 10 minutes, a 20 and 25 wont let it start. So i dont really know what to do with why they are being blown. It is a new Battery and it is fully charged. The solenoid works perfectly fine and i can start it by using a screwdriver to connect the circuit and it starts the fine. Turning on the lights will not blow the fuse only using the electric start on it. If you have any idea of what might be causing this it would help tremendously. (did do a meter test when the key was turned on, everything was correct & no wires are split or pinched etc.)
Reply With Quote
  #2  
Old 08-28-2016, 10:59 AM
Super Quad Patrol
 
Join Date: Aug 2013
Posts: 1,434
Default

has to be a shorted wire some ware in the start circuit.
Reply With Quote
  #3  
Old 01-24-2017, 09:43 AM
Trailblazer
 
Join Date: Jan 2017
Posts: 28
Default

Could it possibly be a short inside the starter to the frame? You could probably take out the starter and make sure it's not touching anything and hit the starter and see if it still blows.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Chinese 110cc no spark MarioA 1) Engine problems.. 1 03-30-2016 09:04 PM
Electric start problem someone help! Ross.B Kawasaki 5 03-09-2016 11:47 AM
Chinese quad wont turn over without removing spark plug... Stuck valve? Robert.unger 1) Engine problems.. 4 03-02-2016 05:22 PM
Fuses involved in the ignition process Kazjag500 1) Engine problems.. 1 02-11-2016 09:50 AM
electric to kick 4trax300ex Performance Mods and Project Quads 1 07-29-2000 11:41 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:08 AM.