Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Honda
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 07-20-2005, 12:52 PM
Specta's Avatar
Pro Rider
Loves riding and can't get enough.
Garage is empty, add now
 
Join Date: Mar 2002
Posts: 3,269
Default 03 Rubicon oil pump problem

We went riding with some people Saturday who just got their 03 Rubicon out of the dealers service dept. The oil pump had gone out and was making a lot of noise.

After putting on roughly 20 miles the engine seized.

What do you think was the cause? Is this common. Did the dealer not do something they should have or maybe left something out?

The did not ride it hard at all. We were riding decent trails.

What would you do?
__________________
2014 750i EPS
new 8/13/2014
805 miles 69.8 hours
Reply With Quote
  #2  
Old 07-20-2005, 02:04 PM
action450s's Avatar
Pro Rider
1998 Honda Foreman
 
Join Date: Sep 2002
Location: NL
Posts: 1,205
Default 03 Rubicon oil pump problem

Bring it back to the dealer. They should fix it, sounds like faulty workmanship to me.
Reply With Quote
  #3  
Old 07-20-2005, 03:56 PM
Specta's Avatar
Pro Rider
Loves riding and can't get enough.
Garage is empty, add now
 
Join Date: Mar 2002
Posts: 3,269
Default 03 Rubicon oil pump problem

I found out today the ATV only has 200 miles on it. They are taking it in this afternoon.

Will keep you posted.
__________________
2014 750i EPS
new 8/13/2014
805 miles 69.8 hours
Reply With Quote
  #4  
Old 08-01-2005, 12:56 PM
Specta's Avatar
Pro Rider
Loves riding and can't get enough.
Garage is empty, add now
 
Join Date: Mar 2002
Posts: 3,269
Default 03 Rubicon oil pump problem

This is what my friend e-mailed to me;

"just wanted to let you know that Steadmans fixed my Rubicon
for free. Those guys are awesome! The recoil starter pulley fell off of the
engine and locked things up. No damage to the engine."

Looks like he is back on the road.
__________________
2014 750i EPS
new 8/13/2014
805 miles 69.8 hours
Reply With Quote
  #5  
Old 08-02-2005, 12:23 PM
Pro Rider
Garage is empty, add now
 
Join Date: Jul 2000
Posts: 485
Default 03 Rubicon oil pump problem

Good to here, funny about the oil pump. Unless you abuse the oil system they should last forever. I don't think I've ever replaced an oil pump on all the engines I've rebuilt. And I use to be in the diesel repair business.
Reply With Quote
Old 08-02-2005, 12:23 PM
Reply

Tags
01, 02, 03, 2001, 2002, atv, engine, honda, oil, problem, problems, pump, rubicon, siezed, water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On