Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Honda
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 11-06-2006, 07:16 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Nov 2006
Posts: 21
Default Flashing D1 D2 ESP on my rubicon, need help.....

So i've done my homework as much as i can as far as history on topics here, i've also done some messing around and some tuning, i've just put a tip on my exuast ( it was lacking one ) and new K & n filter, now i'm going on the oil and filter, I have the same problem as i've heard from many my wheelers in "safe mode" and gets stuck in one gear and doesn't shift,....... if i rev it when i start it up SOMETIMES it will stop flashing and show me a "N" then it goes into drive fine and works just great till about 1-5 min later or when i go more then 40 it goes back to flashing and stays in that gear, i've sprayed down my ecm box with wire dryer and that seems to help get it in to mode but nothing yet on making it stay, i want to do the coolant but don't even where to start......i've tried retriving the codes but it just blinks and blinks never stops, even when the key is on and the wheelers not moving. i'm in need of some serious help, i'm not afraid to get my hands dirty. THANKS u guys rock....
Reply With Quote
  #2  
Old 11-07-2006, 09:12 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Nov 2006
Posts: 4
Default Flashing D1 D2 ESP on my rubicon, need help.....

Okay, I have had this problem on a foreman, turn machine key on in N, but hold your shift buttons, both up and down, turn key on and hold for 10 seconds, then it will flash a certain amount of times, go get a service manual, and look in the codes section, it will flash different for each code it is thorwing, kind of like a check engine light, or let me know how many flashes and I can look it up.
Reply With Quote
  #3  
Old 11-07-2006, 10:38 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Nov 2006
Posts: 21
Default Flashing D1 D2 ESP on my rubicon, need help.....

okay i'll give it another shot, my problem is that when i turn the key it is already flashing ( non stop ) and then if i start and rev, MAYBE i can get it to read N then it works like a charm D1 esp all that, then goes away few min later, sometimes the N will flash for a second when i turn it on, but 95 percent of the time it displays like it reset then goes to flashing, i just took out the ECM and cleaned and dried it. hope that helps. THANKS!
Reply With Quote
  #4  
Old 11-08-2006, 03:17 AM
Weekend Warrior
Garage is empty, add now
 
Join Date: Jul 2006
Posts: 13
Default Flashing D1 D2 ESP on my rubicon, need help.....

Hi, I had the flashing problems too. Mine Coded the "Angle sensor" So I took it back to Abernathy's for warrenty work.
This happened six times before I had 500 miles on it... I figured out on the trail that I could start the motor and put it in drive as fast as I could and give it the gas and it would do "ok" till the bike stopped. You could turn it off and start it again and repeat the process and it would do "ok" again until it slowed or stopped.
Finally Abernathy's got a Honda rep to look at it and they changed the "Motor assembly" and put another "Angle sensor" on it. So far and 150 miles later it's doing good. The "Motor Assembly" is located down at your left ankle if you were sitting on the bike. It is the electric motor that changes the gears...I think...The wire right above the "Motor Assembly" leads to the "Angle Sensor" It's just below the exhaust pipe in the same area.
I have no idea if that's your problem but it sounds like what mine was doing and mine was all under warrenty.... I hope this helps...
Reply With Quote
  #5  
Old 11-08-2006, 09:45 AM
Weekend Warrior
Garage is empty, add now
 
Join Date: Nov 2006
Posts: 21
Default Flashing D1 D2 ESP on my rubicon, need help.....

yes so i think that is VERY possible that you are correct. either that or throttle sensor, anyone know how hard these are to replace? i'll be a expert by the time i'm done with this....



MY daughter turned 7 today..... some dads get there kid a pink bike.... i just got mine a hot pink camo 70cc fourstroke honda with the xtra lg tires OHHH YEA
Reply With Quote
Old 11-08-2006, 09:45 AM
Reply

Tags
06, 2006, 500, d1, d1d2, d1d2and, d2, esp, flashing, foreman, honda, problem, rest, rubicon, showing, stuck



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On