Bombardier DS50 no power - ATVConnection.com ATV Enthusiast Community


Go Back   ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Kids Quads
Search

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-03-2010, 12:35 PM
Trailblazer
 
Join Date: May 2005
Posts: 38
Default Bombardier DS50 no power

Well I fixed the starting problem with my Son's DS50 insalled manual choke. Now after many rides it has no power. When first running will move, but has lack of power. After about 10 minutes the quad will not move. I pickup the rear and give it gas the tires move, but when the tires are touching the ground will not go. Any ideas?????
Reply With Quote
  #2  
Old 05-03-2010, 12:47 PM
scootergptx's Avatar
Supersock
Hired Gun!
"Badges? We don't need no stinkin' badges!"
 
Join Date: Apr 2003
Location: 4th Floor, Footwear
Posts: 108,428
Default

If you're getting full rev from the throttle, I'd look at the clutch and drive system.
__________________
__________________

Becoming an adult has to be the dumbest thing I've ever done.
Reply With Quote
  #3  
Old 05-03-2010, 12:52 PM
Trailblazer
 
Join Date: May 2005
Posts: 38
Default

not getting full rev. from the throttle..
Reply With Quote
  #4  
Old 05-03-2010, 12:56 PM
scootergptx's Avatar
Supersock
Hired Gun!
"Badges? We don't need no stinkin' badges!"
 
Join Date: Apr 2003
Location: 4th Floor, Footwear
Posts: 108,428
Default

Are you getting any backfire or sputter when you try it, or does it just seem like it's not revving up (rpm wise) as it should?
__________________
__________________

Becoming an adult has to be the dumbest thing I've ever done.
Reply With Quote
  #5  
Old 05-03-2010, 01:00 PM
Trailblazer
 
Join Date: May 2005
Posts: 38
Default

no backfire or sputter just does not have the revs anymore...
Reply With Quote
  #6  
Old 05-03-2010, 10:21 PM
oldyeller's Avatar
Pro Rider
 
Join Date: Aug 2003
Posts: 757
Default

I am not sure what year you have so I will assume it is a two stroke..I would do a compression check..Should be at least 90PSI....If that passes is the exhaust tip or muffler plugged up with carbon?..Are you sure the choke is shutting off ok? What colour is the spark plug?

It may also be in the clutches or belt..IF the motor checks out pull the side cover off and take a look..
Reply With Quote
  #7  
Old 05-03-2010, 10:22 PM
Extreme Pro Rider
LT80 Expert
 
Join Date: Mar 2001
Posts: 6,921
Default

First things first, clean the carb, let's eliminate the possibility of a plugged jet.
Pipe plugged?
__________________
VOTE FOR TRUMP!
3x top 10 40+ class
My beloved 250R
300EX
Kymco Mongoose
TRX350 Rancher
mooreracing@windstream.net
814-922-7470
Reply With Quote
  #8  
Old 01-04-2011, 09:21 PM
Weekend Warrior
 
Join Date: Jan 2011
Posts: 2
Default

Mine is doing the same thing. I have put a new cdi box, new carb checked pipe, took out spark arrestor, put new coil pack, new plug, new gas and oil. It still does it. It idles great but once you give it gas it acts like it has very little throttle and it cuts out like it is at a rev limiter. It don't even have enough power to pull off. but you pick the back end up and the tires will turn but not fast.
Reply With Quote
  #9  
Old 01-26-2011, 12:10 PM
Trailblazer
 
Join Date: May 2005
Posts: 38
Default

So I can just pull the spark arrestor out or is it bolted in?? Have not looked at it. Does anybody make a aftermarket exhaust for this little quad?
Reply With Quote
  #10  
Old 01-29-2011, 12:53 AM
Weekend Warrior
 
Join Date: Jan 2011
Posts: 2
Default

Mine is having the same problem with no power!! I am going to pull it apart tomorrow and I will re post an update of what I discover either bad or good.

Chris-
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sudden blowby and hard starting bvolks Kawasaki 8 09-13-2015 12:57 PM
jetmoto 110cc scorpiankill Chinese Quads 2 09-10-2015 09:14 PM
Polaris 2000 xplorer 400cc 4x4 - Flooding? MeadowlarkFarm Test Your Signatures (sigs) Here! 1 09-09-2015 03:50 AM
2000 xplorer 400cc 4x4 - No power when warm MeadowlarkFarm Polaris 1 09-09-2015 03:08 AM
2002 Polaris Sportsman 700 (no power) byronman Polaris 2 09-06-2015 06:34 PM


Tags
50, 50cc, 80, 90cc, atv, belt, bombardier, carb, changing, choke, ds, ds50, manual, move, quad, rev, wont


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:04 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company