Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Polaris
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 09-25-2007, 01:56 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Oct 2006
Posts: 6
Default 700 Sportsman EFI sputters a low RPM

I have a 2006 700 sportsman EFI with 6000 miles on it. When you are running at low RPM's the engine will sputter and sometimes backfire. We put new plugs in but no change. If you run the motor at higher RPM's it runs better. Does any body have any ideal?
Reply With Quote
  #2  
Old 09-25-2007, 08:00 PM
Pro Rider
Garage is empty, add now
 
Join Date: Feb 2006
Location: Whitehorse, YT
Posts: 1,136
Default 700 Sportsman EFI sputters a low RPM

Maybe check your ETC on the throttle cable, it might be out of adjustment. Or maybe your plug wires, see if they are chaffed somewhere. Does it do it all the time?? Maybe a little more info would help
Reply With Quote
  #3  
Old 09-26-2007, 07:10 AM
Weekend Warrior
Garage is empty, add now
 
Join Date: Oct 2006
Posts: 6
Default 700 Sportsman EFI sputters a low RPM

Thanks for the reply. I have already adjusted the ETC, and yes it does it all the time. Some times it does it so bad you think the motor is going to stall. At 30 mph it hardly does it at all, and when you accelerate it seems to run fine. I will check the spark plug wires. Thanks
Reply With Quote
  #4  
Old 09-26-2007, 07:16 AM
stendori's Avatar
Super Quad Patrol
I'm watching you!
Garage is empty, add now
 
Join Date: Jul 2003
Location: central maine
Posts: 13,791
Default 700 Sportsman EFI sputters a low RPM

i dont know what yrs it was but the 700's were having carb boot cracking problems to make it run crappy. i think it was the bottom of the boot. just a thought.
__________________
02'polaris sportsman 500 "freedom"
05' polaris scrambler 500
07' yamaha vstar 1300
10' massey ferguson tractor
Reply With Quote
  #5  
Old 10-01-2007, 07:36 AM
Weekend Warrior
Garage is empty, add now
 
Join Date: Oct 2006
Posts: 6
Default 700 Sportsman EFI sputters a low RPM

After some more checking we have found that the throttle body may be the problem. The butterfly shaft has more play in it than what it should have. We are going to install one in the next couple of weeks. Thanks for the information i will let you know how it turns out.
Reply With Quote
Old 10-01-2007, 07:36 AM
Reply

Tags
30mph, 700, backfires, low, polaris, rpm, sportsman, sputters, throttle, xp



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On