Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Polaris
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 09-17-2009, 08:50 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Sep 2009
Posts: 3
Default 2007 Polaris Sportsman X2 500 EFI Wont Start

I have a 2007 Polaris Sportsman X2 500 EFI. It was running great then stored for about three weeks. The engine will turn but will not start. It has a new battery. I have noticed that the clear hose leading from the fuel tank to the gauge panel has air bubbles in it. Fuel gauge marks empty but it has a full tank. Any suggestion on what to do next would be greatly appreciated.
Reply With Quote
  #2  
Old 09-17-2009, 08:52 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,341
Default

First off do you hear the fuel pump prime up when key is turned on?
Reply With Quote
  #3  
Old 09-17-2009, 08:58 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Sep 2009
Posts: 3
Default

No I dont.
Reply With Quote
  #4  
Old 09-17-2009, 09:20 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,341
Default

Quote:
Originally Posted by TxGirl View Post
No I dont.
If fuel pump problem then if you take it to a dealer they will sell you a complete tank/fuel pump assy. NOT cheap! Some other poster have found replacement pumps at Napa auto and other suppliers. Hopefully they will chime in! I'm at a dealership and my hands are tied at the present time! OPT
Reply With Quote
  #5  
Old 09-17-2009, 09:38 PM
dirtjunkie's Avatar
Range Rover
Garage is empty, add now
 
Join Date: Sep 2009
Location: Texas
Posts: 135
Default

check fuses first
Reply With Quote
  #6  
Old 09-17-2009, 09:46 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,341
Default

Quote:
Originally Posted by dirtjunkie View Post
check fuses first
YEP!!! Forgot about that OPT
Reply With Quote
  #7  
Old 09-18-2009, 03:32 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Sep 2009
Posts: 3
Default 2007 Polaris Sportsman X2 500 EFI

Thank you all for the help!
Where would the fuse panel be located, I have looked everywhere and do not see any fuse panel.
Also today I emptied the gas tank and refilled with new gasoline added some sea foam and then put in a new spark plug. I put some sea foam in with the spark plug as a local mechanic suggested. I waited about five minutes then tried to start it. Well it fired up then died. What should be my next step??
Reply With Quote
  #8  
Old 09-18-2009, 04:24 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,341
Default

Quote:
Originally Posted by TxGirl View Post
Thank you all for the help!
Where would the fuse panel be located, I have looked everywhere and do not see any fuse panel.
Also today I emptied the gas tank and refilled with new gasoline added some sea foam and then put in a new spark plug. I put some sea foam in with the spark plug as a local mechanic suggested. I waited about five minutes then tried to start it. Well it fired up then died. What should be my next step??
Was thinking about the 700-800 on fuse panel! Check the 2 wire connector going to pump,if has power with a test light or meter,then suspect pump problems. Access to connector under front panel towards the top right side leading to tank.
Reply With Quote
Old 09-18-2009, 04:24 PM
Reply

Tags
2007, 500, efi, fuel, fuses, plug, polaris, pump, replacement, spark, sportsman, sportsmanx2, start, tank, wont, x2



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On