Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Polaris
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 07-20-2010, 05:51 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Jul 2010
Posts: 3
Default 2005 polaris 700 EFI fuel problems?

I have a 2005 or late 2004 as they call it after riding for a while when its hot out it starts to sputter bad will not idle like a lack of fuel.If i let it sit for 30 mins. or so it is usually fine but will do it again later. have ridden it at night when its cool and had no trouble but I am not running it hard. If anyone could help me I sure would appreciate it.I thought fuel pump at first but if its bad its bad right? thank you
Reply With Quote
  #2  
Old 07-20-2010, 06:58 PM
JCDEYO25's Avatar
Pro Rider
Garage is empty, add now
 
Join Date: Sep 2005
Posts: 1,604
Default

Yea sounds to be fuel pump issues...do a search on it...just remember get the after market one from Autozone rather than buying the whole setup from polaris....Airtex #E8198 for about $80 and the strainer for about $5 #FS111...Or I think napa has one also...#NFPP7118..

John
__________________
2005 Sportsman 700 EFI camo
800 header pipe, 800 intake
symtec winter pak
3 light mod, reverse light mod(DK)
EPI front springs
2 in. custom rear receiver
stick stoppers
Reply With Quote
  #3  
Old 07-20-2010, 07:20 PM
helmethair78's Avatar
Range Rover
2005 Polaris Sportsman
 
Join Date: Mar 2009
Posts: 155
Default

If you're fuel tank gets too hot it will do a kind of vapor lock. Some reflective heat tape on the bottom of the tank will help, but not eliminate the problem.
__________________
PICKET SIGN " VOTE NO for MEXICO! PLEASE keep the POLARIS ATV's assembly here in the U.S.A!"
Reply With Quote
  #4  
Old 07-21-2010, 03:17 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Jul 2010
Posts: 3
Default

I ll give it a try thank you!
Reply With Quote
  #5  
Old 07-21-2010, 05:25 PM
stendori's Avatar
Super Quad Patrol
I'm watching you!
Garage is empty, add now
 
Join Date: Jul 2003
Location: central maine
Posts: 13,817
Default

welcome to the forum. check the vent hoses to make sure there not plugged or pinched. if not it does sound like a fuel pump issue. do a search and you'll see alot of post of this and a cheap replacement instead of buying a whole gas tank.
__________________
02'polaris sportsman 500 "freedom"
05' polaris scrambler 500
07' yamaha roadstar 1700
10' massey ferguson tractor
Reply With Quote
  #6  
Old 07-16-2011, 09:36 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Jul 2011
Posts: 2
Default

Great info. I just needed the $5.00 dollar fuel pump strainer.
You saved me $500 dollars.
Thanks
August
Reply With Quote
  #7  
Old 07-19-2011, 05:36 PM
JCDEYO25's Avatar
Pro Rider
Garage is empty, add now
 
Join Date: Sep 2005
Posts: 1,604
Default

Glad we helped ya out...welcome to the forum...

John
__________________
2005 Sportsman 700 EFI camo
800 header pipe, 800 intake
symtec winter pak
3 light mod, reverse light mod(DK)
EPI front springs
2 in. custom rear receiver
stick stoppers
Reply With Quote
  #8  
Old 03-13-2012, 10:28 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Mar 2012
Posts: 3
Default

Hey can anyone help i just bought a 07 polaris 800 efi sportsman its been sitting for a year it was needing a on off switch on the handlebars after replacing this i couldnt get it to start after checking the fuel pump wasnt pumping is there a fuse or any thing i need to check
Reply With Quote
  #9  
Old 03-13-2012, 10:31 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Mar 2012
Posts: 3
Default polaris 800 efi sportsman fuel pump problems

Can anyone give me any ideas i just bought this 800 its been sitting up for a year the guy said it needed an on off switch on the handle bars. but after i replaced it. It would crank but i wasnt getting any fuel. after checking the fuel pump it wasnt pumping . Is there a fuse i need to check or anything thats common with this model
Reply With Quote
  #10  
Old 03-14-2012, 12:47 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,783
Default

Welcome to the forum! Did you drain and replace with fresh fuel? Have a new battery? Plus when you turn the key on you don't hear the pump as you say? I so then could be the pump is bad. Others should be able to give you the correct after market pump numbers instead of having to buy a complete tank assy from Polaris! Hang on you'll get some answers OPT
__________________
Retired and loving it! (Main job now,wake up the wife to go to work!)
92 Honda Night Hawk 750 (5500 actual miles)
2000 Chevy Silverado 1500 Sport side (270,000 miles,semi retired)
Whats right is whats left after you do everything else wrong (Robin Williams) RIP
Don't pick a fight with an old man,if he can't fight he'll just shoot ya!
Reply With Quote
Old 03-14-2012, 12:47 PM
Reply

Tags
2005, 700, 800, atv, codes, efi, engine, fuel, gas, lock, mileage, polaris, polaris700efi, poor, problems, pump, sportsman, vapor



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On