Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Polaris
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 05-19-2013, 08:00 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Apr 2011
Posts: 9
Default '11 Ranger Diagnostic Mode Problems

500 EFI machine. So simple, reading right from the manual how to get into diagnostic mode. Off for at least 10 seconds. Machine in park. Press mode button. Turn key to on and release when display lights up. Cant get in to reset wrench icon and change hours. Just goes into the regular display mode. Any pointers as to what I'm doing wrong?

Brian
Reply With Quote
  #2  
Old 05-19-2013, 08:15 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,591
Default

Once in the diagnostic mode toggle to the wrench symbol (hrs) then If I remember correctly hold the button down and the wrench will flash,let up and you can then set it to off if you wish,or toggle through to how many hrs you want it to flash again for service. Once at the selected hrs let it flash until it stops and turn the key off. Goes from 1-250 hrs. I might be right, or I might be wrong on this one. Slowly forgetting some things...
__________________
Retired and loving it! (Main job now,wake up the wife to go to work!)
92 Honda Night Hawk 750 (5500 actual miles)
2000 Chevy Silverado 1500 Sport side (270,000 miles,semi retired)
Whats right is whats left after you do everything else wrong (Robin Williams) RIP
Don't pick a fight with an old man,if he can't fight he'll just shoot ya!
Reply With Quote
  #3  
Old 05-19-2013, 09:38 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Apr 2011
Posts: 9
Default

Thanks. I wish I could get that far. I cant even get in to the diagnostic mode. Tried what the manual says, tried all kinds of other things. Display lights up normal. Toggling just gives me the regular options. Wrench never shows up.

Brian
Reply With Quote
  #4  
Old 05-19-2013, 09:47 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,591
Default

Try holding the button down while the key is off and turn the switch on and off three times,third time on the diagnostic screen should display.OR quickly turn the ignition switch on and off three times without holding the button within 5 seconds. One way or the other the diagnostic screen should come up.
__________________
Retired and loving it! (Main job now,wake up the wife to go to work!)
92 Honda Night Hawk 750 (5500 actual miles)
2000 Chevy Silverado 1500 Sport side (270,000 miles,semi retired)
Whats right is whats left after you do everything else wrong (Robin Williams) RIP
Don't pick a fight with an old man,if he can't fight he'll just shoot ya!
Reply With Quote
  #5  
Old 05-19-2013, 09:56 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Apr 2011
Posts: 9
Default

OK. Thanks for that. Will try tomorrow and let you know.

Brian
Reply With Quote
  #6  
Old 05-20-2013, 09:07 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Apr 2011
Posts: 9
Default

I tried your methods and still nothing. The mode button does work toggling thru the screen. But I can't get into diagnostic mode.
Reply With Quote
  #7  
Old 05-21-2013, 10:39 AM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Garage is empty, add now
 
Join Date: Jun 2008
Location: North Texas
Posts: 12,591
Default

Disconnect the battery for 30 seconds or so,then try again,but have it in neutral this time. Try again according to your manual. If you still can't get it to toggle through the modes the speedo could be defective.
__________________
Retired and loving it! (Main job now,wake up the wife to go to work!)
92 Honda Night Hawk 750 (5500 actual miles)
2000 Chevy Silverado 1500 Sport side (270,000 miles,semi retired)
Whats right is whats left after you do everything else wrong (Robin Williams) RIP
Don't pick a fight with an old man,if he can't fight he'll just shoot ya!
Reply With Quote
Old 05-21-2013, 10:39 AM
Reply

Tags
2011, 500, diagnostic, diagnotic, efi, enter, entering, mode, polaris, ranger, resetting, symbol, wrench



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On