Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Suzuki
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 07-29-2009, 10:17 PM
Weekend Warrior
1984 Suzuki LT 185
 
Join Date: Jul 2009
Posts: 8
Default 1984 Suzuki lt 185

Hi I bought the wheeler from a friend and I've got enough of it together to try and have the motor run. I'm curious if the carb is the correct one for it because all the rest of the parts were on the wheeler and look original but the carb came seperate and looked like it was bought from somewhere else came with a price tag hanging off it. When I look it up online some of the other carbs have a priming pump off the side of the float chamber and this one doesn't do I need to find another carb or is this the correct one? I have seen a few like this but it seems inconsistant with what year they were on. Oh and I'm having trouble getting it to start I have spark and fuel but she won't fire I'm gona try and clean out the carb tommorow but any insight on any of this would be great.

Thanks
Reply With Quote
  #2  
Old 07-30-2009, 09:14 AM
Weekend Warrior
1984 Suzuki LT 185
 
Join Date: Jul 2009
Posts: 8
Default

I have the carb all apart on my desk now it seems ok a little dirty so I'm cleaning it out but I didn't see anything that was obviously the problem.
Reply With Quote
  #3  
Old 07-30-2009, 10:17 AM
Weekend Warrior
1984 Suzuki LT 185
 
Join Date: Jul 2009
Posts: 8
Default

Can anyone help me please? This is my first wheeler and I'm not sure whats wrong. I have spark. I have fuel to the carb. When I pull it sounds ok but after 2-3 pulls fuel comes out of the drain from the carb and last time I just did it fuel came out of the drain on the air box. Very confused and frustrated any idea whats going on?
Please
Reply With Quote
  #4  
Old 07-30-2009, 03:30 PM
Weekend Warrior
1984 Suzuki LT 185
 
Join Date: Jul 2009
Posts: 8
Default

So I cleaned the whole carb in and out got a lot of dirt out. Put it back on pulled a LOT of times and got a backfire and 5 to 6 sputters out of her. Anything else I can do to give it that extra push to start? Its so very close.
Reply With Quote
Old 07-30-2009, 03:30 PM
Reply

Tags
185, 1984, atv, carb, carburetor, fuel, lt, lt185, parts, primer, problems, pump, quad, suzuki, system



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On