Carb Problem - Has anyone had this problem - ATV Enthusiast Community

Go Back ATV Enthusiast Community > SxS / UTV Discussion > Yamaha Rhino

LinkBack Thread Tools Search this Thread
Old 06-14-2009, 10:17 PM
Extreme Pro Rider
Join Date: May 2002
Location: Bakersfield
Posts: 3,441
Default Carb Problem - Has anyone had this problem

Top of the carb that holds the needle, I took it off and there was a hole in the side of the rubber diaphram that is matches up with the opening for the throttle, is there something or some way that the vacuum suction from there that would pull the side wall of the rubber diaphram into that? I have found this problem after my rhino was running crappy. 2006 660 is the model. Help....
Reply With Quote
Old 08-17-2009, 09:07 PM
Range Rover
Join Date: Apr 2009
Location: winton,ca.
Posts: 164
Send a message via Yahoo to wheily

there should be no oles in that diaphram they dont run to great like that not sure what could have caused the hole
Reply With Quote
Old 08-22-2009, 12:21 AM
atv parts plus's Avatar
Join Date: Jul 2009
Posts: 38

change diapharm should be ok. is it not opening up full throtle?
"Never argue with an idiot. They drag
you down to their level then beat you with experience."

1100 cc sandblaster

Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
TAO TAO 110cc not running (Got me Stumped) Ty Speece Chinese Quads 15 07-02-2015 05:59 PM
Timberwolf 250 ignition switch/wiring help wildbill59 Yamaha 3 06-09-2015 03:28 AM
2001 325 Magnum Sputtering Problem generalpops Polaris 5 06-05-2015 09:23 PM
Outlaw 50 4-stroke starting problem garyt1975 Kids Quads 2 06-05-2015 09:53 AM
2001 325 Magnum Sputtering Problem generalpops Introduce Yourself 1 06-03-2015 09:25 PM

07, 2006, 660, carb, carburater, carburetor, diaphragm, diaphram, hole, problem, problems, rhino, side, yamaha

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 01:13 AM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company