Blaster: Starts easy...won't rev?! - ATVConnection.com ATV Enthusiast Community



Reply
 
Thread Tools Search this Thread
  #1  
Old 08-22-2005, 12:21 PM
Trailblazer
Thread Starter
 
Join Date: Feb 2000
Posts: 52
Default Blaster: Starts easy...won't rev?!

Please help. I have a 2004 Blaster. All of a sudden it won't rev. It starts easily, but when you give it throttle, it bogs (almost like it is getting too much fuel and no spark). It will run but just pops at a slow rpm. Any help?

Thanks in advance!
Reply With Quote
  #2  
Old 08-22-2005, 12:34 PM
mywifesquad's Avatar
KTM Patrol
Former Chinese POW!
 
Join Date: Jul 2004
Location: Newman, Ca
Posts: 56,460
Default Blaster: Starts easy...won't rev?!

Quote:
Originally posted by: conway400
Please help. I have a 2004 Blaster. All of a sudden it won't rev. It starts easily, but when you give it throttle, it bogs (almost like it is getting too much fuel and no spark). It will run but just pops at a slow rpm. Any help?

Thanks in advance!
I would bet the carb is dirty. Assuming youve put in a new spark plug all ready.
Reply With Quote
  #3  
Old 08-22-2005, 01:30 PM
Pro Rider
 
Join Date: Sep 2004
Posts: 748
Default Blaster: Starts easy...won't rev?!

lets think about this..if it runs at idle (least fuel required and it wont rev up (more fuel required) dont you think you arent getting enough fuel???

check your fuel filter if it has one, then make sure your tank vent is clear, take the line off the carb and open the valve to make sure you have good flow. if all that's good, sounds like you need to take the carb apart and rebuild or clean it.
Reply With Quote
  #4  
Old 08-22-2005, 01:31 PM
Pro Rider
 
Join Date: Sep 2004
Posts: 748
Default Blaster: Starts easy...won't rev?!

oh yeah, the popping probably runnning lean from not enough fuel, also might have air leak, 2-strokes dont like air leaks
Reply With Quote
  #5  
Old 08-22-2005, 03:07 PM
Pro Rider
 
Join Date: May 2004
Posts: 2,689
Default Blaster: Starts easy...won't rev?!

i would also check for airleeks around the carb and head. Also, throw a new plug in if you havent. also check to see fuel is getting to the carb, the fuel line might be clogged. if all fails, take apart the carb and clean it out, your mainjet might be clogged.
Reply With Quote
  #6  
Old 08-23-2005, 11:08 AM
Trailblazer
Thread Starter
 
Join Date: Feb 2000
Posts: 52
Default Blaster: Starts easy...won't rev?!

I got it going. It was the parking brake switch. The bike thought the brake was on and yamaha has that rev limiter connected to it for safety. I jiggled that and it took off just fine. Basically, it just limits your rev to a high idle if it is on.

Thanks for all the replies!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Big Bear starting problem Mkp Yamaha 5 06-23-2015 03:45 AM
Troubleshooting kill switch on a Honda ATV (93 TRX300). tiresharkdbb Honda 9 06-16-2015 03:24 AM
My RACE WRITE-UP from Edgewood Tx (TORN series rd 1) MikeyBoyesq ATV Racing 0 06-09-2015 10:49 PM
Outlaw 50 4-stroke starting problem garyt1975 Kids Quads 2 06-05-2015 09:53 AM
NOS-Atvs - Trail Scouting Extreme (Part 2) 1000gade ATV Videos 0 05-27-2015 01:37 PM


Tags
04 , 250 , 500 , blaster , bogs , clears , cr , give , honda , idle , rev , throttle , wont , xr , yahmaha , yamaha


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:34 AM.