yamaha champ 100 wont start - ATVConnection.com ATV Enthusiast Community


Go Back   ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Yamaha
Search

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-10-2009, 09:23 PM
Weekend Warrior
 
Join Date: Mar 2009
Posts: 13
Default yamaha champ 100 wont start

i have a 87 champ that i replaced a bent intake valve in and now i got good spark compression and even using starting fluid it wont start please help
Reply With Quote
  #2  
Old 07-10-2009, 10:26 PM
Terrellster's Avatar
Pro Rider
 
Join Date: Jan 2008
Posts: 448
Default

Quote:
Originally Posted by slimhappy02 View Post
i have a 87 champ that i replaced a bent intake valve in and now i got good spark compression and even using starting fluid it wont start please help
That one is similar to one of mine,... A slightly slow starter will not turn it fast enough to git 'er runnin'. Use some jumper cables and do a one time start and see if that helps.

If not, it may be time to check the valves again. They're kinda hard to set while the engine is installed, but it can be done. I suspect you already set them on the new valve install, but check them once more and varify timing if the jump start won't do it.
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Buying new vs used? neilbedwell Buying an ATV 23 01-18-2016 12:57 PM
Yamaha Big Bear 400 Yamaha_ Utility ATVs 0 06-08-2015 08:28 PM
93 350L 4x4 first trail ride cornermike Polaris 5 06-03-2015 07:27 AM
NOS-Atvs - Trail Scouting Extreme (Part 2) 1000gade ATV Videos 0 05-27-2015 12:37 PM
Question about Yamaha Champ 250Man400 Buying an ATV 2 06-28-2000 08:57 PM


Tags
100, 87, atv, champ, champs, compression, problem, quad, spark, star, start, time, timing, wont, yamaha


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:21 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company