Artic cat 650 starting problem - ATVConnection.com ATV Enthusiast Community



Reply
 
Thread Tools Search this Thread
  #1  
Old 01-02-2015, 11:56 AM
Weekend Warrior
Thread Starter
 
Join Date: Dec 2014
Posts: 1
Unhappy Artic cat 650 starting problem

Having problems starting put new plugs in noticed a real week spark Check voltage going to the coils it has 31 vdc like the book states but when you turn the engine over it does not change the book states it should go to 100
plus volts. What would be best to check next the trigger coil in the magento?
Any pointers would be greatly appreciated
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My RACE WRITE-UP from Edgewood Tx (TORN series rd 1) MikeyBoyesq ATV Racing 0 06-09-2015 09:49 PM
2001 artic cat please help Jbird4681 General Chat 2 06-09-2015 01:59 AM
2001 325 Magnum Sputtering Problem generalpops Polaris 5 06-05-2015 08:23 PM
Outlaw 50 4-stroke starting problem garyt1975 Kids Quads 2 06-05-2015 08:53 AM
NOS-Atvs - Trail Scouting Extreme (Part 2) 1000gade ATV Videos 0 05-27-2015 12:37 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:21 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send