ATVConnection.com ATV Enthusiast Community - View Profile: LT80



LT80 LT80 is offline

Extreme Pro Rider
LT80 Expert

Visitor Messages

Showing Visitor Messages 1 to 10 of 35
  1. STEVEA3258
    07-01-2017 06:22 PM - permalink
    STEVEA3258
    Hi I'm new here and I see you help alot of people with lt80s I'm hoping you can help me. I put a new top end (eBay) kit into my daughters lt80 started up ran good had good compression about 125-130 followed correct break in procedure and then brought her to ride it at the Oregon dunes the bike ran good for 1st day 2ND day here though it lost power and died couldn't restart it towed it back and it started up she rode again it loss power died again. Compression is still around 125 no engine leaks but when it starts and runs at start up it seems to have an engine knocking sound compared to her brothers lt80 swapped the carbs on their bikes and that didn't solve anything. Thinking maybe wrist pin bearing in the eBay kit went bad and gonna take apart when I get home. I have a wiseco top end kit on order. Any of your insight is greatly appreciated thank you
  2. wtwolfe
    06-27-2017 10:12 PM - permalink
    wtwolfe
    LT80, Hello, I am new here. I saw you had some answers for others and I was hoping you could do it again. I just acquired a1987 LT80 that is not running. It ran when it was parked 2+ years ago. Someone started to take the carb out, and left it disassembled. I am not sure which line goes where. I have a main fuel line, I know where that one goes. Also have 2 small tubes that go to a T in the air filter housing. I have also read a bit about these quads and realize that they are oil injected. This one is not. Perhaps someone removed it already. I am assuming the injector line would go to the brass fitting behind the choke, on the left side , I will need to plug that fitting off? And what about the lines from the airbox? I see 3 ports on the rt side, The lower one is the fuel inlet. What are the other 2? I I can post pictures if it would help. I also noticed the chain looks very slack. looks like someone tried to do mouse a tensioner? Thank you for any help. Bill
  3. roger6632
    05-15-2017 02:27 PM - permalink
    roger6632
    i had a friend rebluid the card/i put a honda fuel pump on/new filter/plug/checked gas cap vent,was good real hard starting when cold out instead of killing starter i use a heat gun on the head after a few minuts it starts,starting to wonder if my friend rebult it right?
  4. Bonanza35
    01-28-2017 01:39 PM - permalink
    Bonanza35
    Jack, haven't heard from you, just wondering how my grand kids motor work is going. I know your going on vacation
    chet
  5. Cobra_Kid
    11-20-2016 08:34 PM - permalink
    Cobra_Kid
    Roller Chain Style: Single Strand Chain 35309624 - MSC

    Is the above link the type of chain you buy? I have an 06 with a 10/22 sprocket set, but i'd need to buy some 428 sprockets correct and i'd go 11/22 if i did for the #40 chain.
    Thanks, Troy
    p.s. Go Trump! Glad he won!
  6. Sdamato924
    09-28-2016 09:38 PM - permalink
    Sdamato924
    Hello Jack . My name is Sal and I live in Connecticut. I'm currently in the middle of doing some work on my son's 1992 Lt80. This is my second time going through this quad. The first time was to just go through it clean it up and replace anything it needed. This time I wanted to give it a little more horsepower. I have the top end off carb and both clutches apart. I don't have any problems with cutting the rear clutch and taking out 2 rollers. I really don't have anyone around here to machine the head for me. So can I get a estimate for some of the different types of upgrades you can do if I sent you the top end?
    Thank you Sal
    My email if you would rather talk through that is [email protected]
  7. Brandon.peterson
    02-28-2016 09:05 PM - permalink
    Brandon.peterson
    Hey lt80. So I replaced the top end on my lt80 this week and a rode it for about 10 minutes it had a lot of power and the compression was at 125pd. But I blew the top gaskets and replaced them thinking they where bad from the factory. But I only got about 5 minutes of riding in before I blew them too. Any ideas?

    -Brandon
  8. xchaser
    12-09-2015 02:55 PM - permalink
    xchaser
    hi there LT80, I have used your forums for quite a few repairs /troubleshooting. For that I thank you for your abundance of knowledge on these at times painful quads. I have a slightly confusing repair that I thought id run by you. I have a 96 LT80 that needed a new CDI, the only one I could source was one off a 03 model which as you know is slightly different. Obviously there are 2 extra wires on the later model that need to be put somewhere. I thought I had it worked out but still cant get spark. Can you assist here? Has anyone attempted to do this conversion? I am thankful for any assistance you can offer. Cheers.
  9. mbriggs
    09-12-2015 11:56 AM - permalink
    mbriggs
    i pulled the tank to put a new petcock on and noticed the foam on the airbox is shot. I can't find it anywhere online. It's appears it is sold as part of the air box itself. It seems to be foam that seals the airbox to the bottom of the tank. any ideas? how can i replace this foam?
  10. vintage_lt
    04-06-2015 01:51 AM - permalink
    vintage_lt
    Hi LT80,
    I see that you seem to know a lot about these little machines! I own a 1987 lt80 that is in pieces in the shed. I would like to rebuild it and im wondering what are the best options for me. I have noticed the CT racing package and also midwest. Also looking at getting new wheels and tyres or possible just tyres.
    Could you please lend some advice ?
    Thanks in advance
    Drue

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 07-21-2017 01:44 PM
  • Join Date: 03-24-2001
  • Referrals: 4

Friends

Showing Friends 1 to 13 of 13

All times are GMT -5. The time now is 05:28 AM.