2003 Polaris 330 cranks but wont start - ATVConnection.com ATV Enthusiast Community

Polaris Ask an Expert! In fond memory of Old Polaris Tech. An area where experts in their field will answer non-general questions about your Polaris ATV.
"old polaris tech" and other experts will answer your questions as they have time.
ASK ALL GENERAL QUESTIONS OR BASIC QUESTIONS IN THE POLARIS FORUM.
Basic or General questions posted in a expert section will be moved!

2003 Polaris 330 cranks but wont start

Reply

  #1  
Old 06-13-2014, 12:19 PM
N2ROW's Avatar
Weekend Warrior
Thread Starter
Join Date: Jun 2014
Location: NYC
Posts: 7
Default 2003 Polaris 330 cranks but wont start

So this winter the Polaris started right up. I warmed it up for about 20 min. I shut it down for 15 min. I came back out to restart and nothing. Cranks and cranks nothing. Played with choke nothing. I sprayed some starter fluid in the air intake it attempted to start but it didnt hold. I tried recently again now thats its warm out. She cranks puffs a little attempts to start but nothing. Fuel is filled to the top. I switched form normal fuel position to serve and back. Battery voltage good. Now that its camping season I need to get it running. I lost out of all the snow we had in NY. Any suggestion since im taking the skin off the bike tonight?
Richie
2003 Trailboss 330
 
Reply With Quote
  #2  
Old 06-13-2014, 06:11 PM
Jaster94's Avatar
Extreme Pro Rider
Join Date: Jun 2009
Location: Texas
Posts: 3,224
Default

yeah, pull the spark plug and test for spark. try replacing the spark plug. check all of your kill switches. how to you shut it off? do you use the key or the red slider kill switch? check that out. test for spark.
 
Reply With Quote
  #3  
Old 06-13-2014, 07:38 PM
N2ROW's Avatar
Weekend Warrior
Thread Starter
Join Date: Jun 2014
Location: NYC
Posts: 7
Default

Will do within an hour. I will advise. Thanks
 
Reply With Quote
  #4  
Old 06-13-2014, 11:52 PM
N2ROW's Avatar
Weekend Warrior
Thread Starter
Join Date: Jun 2014
Location: NYC
Posts: 7
Default

I have spark. I pulled the plug out cleaned it and reinstalled it. Sprayed some starting fluid and cranked it. It started for about 40 seconds giving it trottle with no response she shut down. More spray she fired up and puff. I removed the fuel line that goes into the filter. I cranked it and fuel started to come out but it seemed very low pressure it barely wanted to come out as the engine turned. I then removed the fuel line from the switch which came from the tank, it started to pour out. So does it seem the fuel pump went bad? Or should it pour out with lots of pressure to fill the carburator? Is this normal to pulse fuel out at a dribble? And that's at all settings of the fuel selector valve.
 
Reply With Quote
  #5  
Old 06-14-2014, 07:18 AM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Join Date: Jun 2008
Location: North Texas
Posts: 24,352
Default

Check fuel flow in the on position and also reserve and see if it's the same when you crank the engine over. Fuel valves can stop up along with fuel filters. If you eliminate these as the problem plus the vacuum line to the carb is secure,fuel pump could be weak or have dirt and trash in it. Fuel flow can pulse,but it should be more than a dribble. You can use a Mityvac also to pull a vacuum on the impulse line at the carb to see if the fuel flow is the same.If it is,then probably needs a fuel pump. Plus don't over look needing a carb kit if it's been sitting up for awhile.Even more so if you don't have stabilizer in the fuel. Dirt Cheap Yamaha, Honda, Arctic Cat & Polaris OEM Parts & Accessories – Cycle Parts Warehouse
http://www.jetsrus.com/individual_parts/sh_03_409.html
 
Reply With Quote
  #6  
Old 06-14-2014, 11:23 AM
N2ROW's Avatar
Weekend Warrior
Thread Starter
Join Date: Jun 2014
Location: NYC
Posts: 7
Default

Thanks. Fuel flow is the same on both positions. Before the filter that goes in the carb. Question I didn't trace it but I removed the air box. There was a hose I disconnect. Is that hose connected to the pulse side of the pump? Otherwise I will need to retest with the air filter box connected and sealed? Now I need a new 3 way valve it snapped removing the fuel line. Frustrating lol. I have one side working for now.
 
Reply With Quote
  #7  
Old 06-14-2014, 05:19 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Join Date: Jun 2008
Location: North Texas
Posts: 24,352
Default

Air box and filter need to be in place and top on or it will be hard to start and run right. These machines are cold natured and lean running as it is..Hose at the air box comes from the crank case vent at the top of the engine. Item #7 on the crank case vent. Dirt Cheap Yamaha, Honda, Arctic Cat & Polaris OEM Parts & Accessories Cycle Parts Warehouse
 
Reply With Quote
  #8  
Old 06-17-2014, 11:51 AM
N2ROW's Avatar
Weekend Warrior
Thread Starter
Join Date: Jun 2014
Location: NYC
Posts: 7
Default

OK, I orderd a new fuel pump, filter and fuel switch since I broke it pulling the hose off. I will update when I get it and install it.
 
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
neilbedwell
Buying an ATV
24
11-10-2018 12:02 PM
Hankey Pankey
Polaris Ask an Expert! In fond memory of Old Polaris Tech.
24
06-28-2018 05:49 PM
tiresharkdbb
Honda
11
09-03-2017 03:06 AM
Thanos
Polaris
17
07-12-2015 09:40 PM
1000gade
ATV Videos
0
05-27-2015 01:37 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2003 Polaris 330 cranks but wont start


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: