07 sportsman 500 nothing works - ATVConnection.com ATV Enthusiast Community



Reply
 
Thread Tools Search this Thread
  #1  
Old 03-19-2017, 06:44 PM
Range Rover
Thread Starter
 
Join Date: Jan 2014
Posts: 140
Default 07 sportsman 500 nothing works

Hi opt unfortunately back on here again trying to figure out what is going on now. Bought an 07 sportsman 500 efi a month ago and haven't had any problems. Last time I drove it it ran fine when I went to park it the only think I did different was I flipped the red kill switch on accident. I put it back to run then turned the key off. I just went to start it and turned the key and nothing lit up on the speedometer, no headlights. I thru the battery charger on the wheeler and walked away. Came back 15 min later and turned the key and the display lit up and the check engine light was flashing. I turned the key off and came back an hour later and turned the key and nothing. I put a volt meter on the batter and had 13.8 volt. It's a new battery. I don't know where to start or what to look for. Thanks
Reply With Quote
  #2  
Old 03-20-2017, 10:10 AM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 21,011
Default

Check the left control switch connectors going down into the main harness along with making sure the two connectors at the switch are clean and tight. That may be the problem. Other than that,the most common problem on these were the ecm/pdm module under the front panel.You may be able to check voltage going in and out with the key on and be able to tell. High dollar module as the circuit breakers,etc are all in this box.Item#11.
Attached Thumbnails
07 sportsman 500 nothing works-b72c8065345961360a3346e7049275beeaadc637.png  
Reply With Quote
  #3  
Old 03-20-2017, 01:49 PM
Range Rover
Thread Starter
 
Join Date: Jan 2014
Posts: 140
Default

Do you know the ohms that the switch should read at the connectors? I took the 2 off and they were very dirty and muddy. I cleaned them up and reinstalled them. Also where do I check for power with the key on?
Reply With Quote
  #4  
Old 03-20-2017, 02:02 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 21,011
Default

Don't know,but the manual has tests on the pdm module that can determine if it's the problem or not.Better than throwing 400 bucks at a new one on a guess. May be as simple as the left control switch.2007 Polaris Sportsman 500 EFI Service Manual PDF Download
Reply With Quote
  #5  
Old 03-21-2017, 05:38 AM
Range Rover
Thread Starter
 
Join Date: Jan 2014
Posts: 140
Default

When I got home last night I went out to the wheeler and turned the key and everything lit up as it should. I tried to start it and the battery didn't have enough juice to turn the wheeler over. The battery only had 11.2 volts. I put the battery charger on the battery and this morning I turned the key and nothing lit up. Seems like a bad connection. Have you seen the computer work and not work? In vehicles when they go they go usually.
Reply With Quote
  #6  
Old 03-21-2017, 05:41 AM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 21,011
Default

With this pdm module,anything can happen. Recheck battery cables connections,etc. One other function of the pdm module is that it has the regulator built in. Another reason it can be the cause of the battery low voltage,drain.etc.
Reply With Quote
  #7  
Old 03-21-2017, 11:38 AM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 21,011
Default

If you narrow it down to the pdm module,this place rebuilds them for 150 bucks.https://modulemaster.com/rebuilds/sh...bution-module/
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:31 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send