99 Sportsman 335 runs way rich won't idle - ATVConnection.com ATV Enthusiast Community

Go Back  ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Polaris
Reload this Page >

99 Sportsman 335 runs way rich won't idle

Polaris Discussions about Polaris ATVs.
Sponsored by:
Sponsored by:

99 Sportsman 335 runs way rich won't idle

  #1  
Old 03-05-2019, 10:41 PM
Weekend Warrior
Thread Starter
Join Date: Mar 2019
Posts: 3
Default 99 Sportsman 335 runs way rich won't idle

I picked this bike up with this pre-existing condition so I don't know how it got this way. Thought it would be an easy fix but it's really frustrating me. 1999 Polaris Sportsman 335. Will not idle for more than a few seconds, runs very rough and misses at lower rpm's. Choke/enricher has no effect at all on how the engine runs. Hot or cold it makes no difference.Starts up with no choke every time. I cleaned and put a kit in carb, changed air filter, fuel filter, new fuel pump, new plug. Replaced CDI with RM stator DC conversion, new coil. Nothing has made a bit of difference. Compression is 80psi. I even checked the cam lobes and they look good. Spark plug is sooty black within a few minutes of running. Does anybody have any ideas about what could possibly be going on with this thing? I'm about out of ideas. Bike runs terrible!
 
  #2  
Old 03-06-2019, 02:32 PM
stendori's Avatar
Super Quad Patrol
I'm watching you!
Join Date: Jul 2003
Location: central maine
Posts: 14,140
Default

well 80 psi would be first issue I would say as it should be way more then that. maybe valves aren't closing all the way if they are time to look at piston/rings. good luck
 
  #3  
Old 03-06-2019, 08:53 PM
Weekend Warrior
Thread Starter
Join Date: Mar 2019
Posts: 3
Default

Manual states 50-80 psi is acceptable. These engines have a compression release.
 
  #4  
Old 03-07-2019, 02:54 PM
stendori's Avatar
Super Quad Patrol
I'm watching you!
Join Date: Jul 2003
Location: central maine
Posts: 14,140
Default

wow am I ever shut in the 2 stroke world lol. you think I should have known that since I owned the very same year bike. sorry about that.
 
  #5  
Old 03-14-2019, 08:46 AM
Weekend Warrior
Join Date: Dec 2003
Posts: 2
Default

Sounds similar to my situation with my xplorer 300, except mine will idle, just won't take throttle, falls on its face and backfires. Been thinking maybe the timing, but not sure.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mike O
Polaris Ask an Expert! In fond memory of Old Polaris Tech.
0
03-02-2019 08:32 PM
Wenty
Polaris
8
12-01-2010 12:35 AM
WyoBullRydr
Other ATV Topics
33
03-24-2005 04:44 AM
1mojave
Kawasaki
3
02-05-2004 12:14 AM
BuyAmerican
Polaris
13
09-07-2001 12:32 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 99 Sportsman 335 runs way rich won't idle


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: