Polaris Discussions about Polaris ATVs.
Sponsored by:
Sponsored by:

2003 Polaris sportsman 400

  #1  
Old 05-25-2019, 06:54 PM
Weekend Warrior
Thread Starter
Join Date: May 2019
Location: Texas
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default 2003 Polaris sportsman 400

Hey y'all, new here. I have a 2003 sportsman 400 that idles just fine and revs up to wot in neutral with no bog, nothing! When at ,what I guess is full speed it starts slowing Down like it has a governer. As it bogs down, If I keep it at 1/4 throttle it drives slow with no problem. It has pretty good power until I get up to speed then it's all down hill from there. I've checked for vacuum leaks and checked the filter. All seems fine. I sprayed carb cleaner around the intake and air box. No headway... Anyone have a clue!?
 
  #2  
Old 05-26-2019, 10:48 AM
850 trailrider's Avatar
Range Rover
Join Date: Apr 2010
Location: millbury ma
Posts: 175
Likes: 0
Received 0 Likes on 0 Posts
Default

Fuel pump ? pull fuel line off carb. check[safely] for steady steam of fuel while turning over? clogged screens in fuel tank, Bad gas? keep us posted
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trbojet1
Polaris
14
10-12-2017 04:33 PM
cmatthews24
Utility ATVs
3
03-03-2005 02:21 PM
lvflyer
Buying an ATV
6
02-20-2003 03:53 PM
jtdavis
Buying an ATV
0
12-22-2002 11:05 PM
Pierce
Arctic Cat
6
10-05-2001 02:13 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2003 Polaris sportsman 400


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: