Go Back  ATVConnection.com ATV Enthusiast Community > General Discussion > Polls
Reload this Page >

Gauge cluster turns on & off continuously Help please!

Polls Post your Polls here

Gauge cluster turns on & off continuously Help please!

  #1  
Old 04-02-2016, 09:03 PM
Weekend Warrior
Thread Starter
Join Date: Apr 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Gauge cluster turns on & off continuously Help please!

Hello, I have a 2006 Arctic Cat 700. The battery had died while sitting over the winter. I replaced the battery. I then turn the key. The gauge turns on then off continuously.........

I am able to start the engine & operate the quad. But the gauge keeps turning on and off. Anyone have any ideas as to why this is happening?

Thank you!
 
  #2  
Old 04-03-2016, 05:11 AM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Join Date: Jun 2008
Location: North Texas
Posts: 24,352
Likes: 0
Received 0 Likes on 0 Posts
Default

Have you tried disconnecting the gauge and see if it resets?
 
  #3  
Old 04-03-2016, 06:11 PM
Weekend Warrior
Thread Starter
Join Date: Apr 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by old polaris tech View Post
Have you tried disconnecting the gauge and see if it resets?
Thank you for your help! I disconnected the gauge. Cleaned the connection. Plugged it together. Tried again. Machine runs and functions 100%. Just the entire gauge still turns on and off repeatedly. The speedo is sitting at 10km.

Curious if this is the computer telling us something?
 
  #4  
Old 04-03-2016, 08:00 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Join Date: Jun 2008
Location: North Texas
Posts: 24,352
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by JonesE View Post
Thank you for your help! I disconnected the gauge. Cleaned the connection. Plugged it together. Tried again. Machine runs and functions 100%. Just the entire gauge still turns on and off repeatedly. The speedo is sitting at 10km.

Curious if this is the computer telling us something?
You might try to see if you can go past the speed it's frozen at and see if the speedo resets then. Just a thought..
 
  #5  
Old 04-10-2016, 12:14 PM
Weekend Warrior
Thread Starter
Join Date: Apr 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Hello, I drove up over 30k. Nothing changed. I find it interesting that it is stuck at 10km. Then the gauge light continues to turn on n off. Any other suggestions?
 
  #6  
Old 04-10-2016, 04:23 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
Join Date: Jun 2008
Location: North Texas
Posts: 24,352
Likes: 0
Received 0 Likes on 0 Posts
Default

Only thing I'm down to is if the service manual can help. Can't seem to find a 2006,only a 2007 for 5 bucks.2007 Arctic Cat 700 EFI ATV Service Manual PDF Download Definitely sounds like something happen to the speedo when the battery drained down.. You might see if this FREE pdf link works first..http://www.mymowerparts.com/pdf/Arct...ice_manual.pdf
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Timbo2500
Yamaha
14
03-15-2016 10:30 AM
blueblaster88
1) Engine problems..
5
03-08-2016 09:25 AM
200es
Yamaha
1
03-07-2016 06:01 PM
400exWarner
Technical and How-To Articles
1
03-06-2016 03:27 AM
Barnsnelbon
Polaris
6
03-05-2016 02:47 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Gauge cluster turns on & off continuously Help please!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: