03 suzuki eiger no spark - ATVConnection.com ATV Enthusiast Community



Suzuki Discussions about Suzuki ATVs.

Reply
 
Thread Tools Search this Thread
  #1  
Old 02-23-2017, 08:08 AM
Weekend Warrior
Thread Starter
 
Join Date: Mar 2016
Posts: 1
Default 03 suzuki eiger no spark

hey guys and girls I have a 03 eiger and I was driving it and it died then wont start but neutral lights not coming on I think is my neutral safety switch any one had this before
Reply With Quote
  #2  
Old 02-24-2017, 02:47 AM
Pro Rider
 
Join Date: Oct 2013
Location: Lancaster England
Posts: 2,088
Default

Yes, but the neutral light won't come on if the ignition isn't on. So, does the reverse light work. Faulty ignition switches, slack battery terminals, blown main fuse (on the solenoid) are all causes of ignition circuit failure. If all other circuits come on with the ignition, there is a relay for the neutral light circuit, can't remember if it is the one by the voltage regulator or the one at the side of the fuse box but it could be a fault with that.
Reply With Quote
  #3  
Old 05-02-2017, 12:06 PM
Weekend Warrior
 
Join Date: Mar 2017
Posts: 18
Default

will it crank and not start, if so i just replaced my stator and magneto setup as one of the magnets had come loose, no damage but wouldn't make a spark
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:51 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: