2017 king quad 750 no start - ATVConnection.com ATV Enthusiast Community

Suzuki Discussions about Suzuki ATVs.

2017 king quad 750 no start

Reply

  #1  
Old 10-08-2018, 10:52 PM
Weekend Warrior
Thread Starter
Join Date: Oct 2018
Posts: 2
Default 2017 king quad 750 no start

i have a 750 king quad that has multiple codes after changing the fuel pump
no codes before changing it
c13 c14 c15 c21 c23
please help
 
Reply With Quote
  #2  
Old 10-09-2018, 03:14 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,284
Default

I'm not at work to check what those codes are, but double check that you have re-connected all those wiring plugs that had to come off when you removed the rear plastic. Dead easy to miss poking one back through when you re-fit the plastic.
 
Reply With Quote
  #3  
Old 10-09-2018, 03:54 PM
Weekend Warrior
Thread Starter
Join Date: Oct 2018
Posts: 2
Default No start

Check all connections all looks good
Do I need to reset codes
 
Reply With Quote
  #4  
Old 10-12-2018, 02:43 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,284
Default

You can try it, most of those codes are to do with the throttle body and sensors on it. You don't need to disconnect the throttle body wires to change a pump, but did you?
 
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kcebcj
Polaris
23
01-20-2018 03:51 PM
Pete2411
Suzuki
4
02-22-2007 11:48 PM
aksafari
Suzuki
1
08-03-2004 12:16 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2017 king quad 750 no start


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: