Suzuki Discussions about Suzuki ATVs.

Suzuki LT80 - No Top End Power

  #1  
Old 06-24-2019, 11:55 AM
Weekend Warrior
Thread Starter
Join Date: Jun 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default Suzuki LT80 - No Top End Power

Hello!

I just recently purchased an 01 LT80. Iíve noticed that it doesnít seem to really have much for top end. As you ride the bike it seems that from a stand still the bike takes off great. Then as you get into the top end of RPM, it seems to sputter and feels like it hits a ďrev limiterĒ in some sort. Iíve read about the carb being restricted. Thereís no brass ring. Iíve also read about there being a ďwasherĒ in the exhaust. I removed the exhaust and didnít really see anything that would point to there being a washer inside the exhaust. I was told it has recently had a top end done by a reputable bike shop close to me. Any help would be GREATLY appreciated! Thanks!!
 
  #2  
Old 06-25-2019, 03:32 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,850
Likes: 0
Received 4 Likes on 4 Posts
Default

Exhausts can block up with carbon, or a small piece of dirt could be restricting the main jet. Also possible someone has been "messing" with the carb, altering float height or main jet etc.
 
  #3  
Old 06-25-2019, 07:38 AM
Extreme Pro Rider
LT80 Expert
Join Date: Mar 2001
Posts: 7,951
Received 2 Likes on 2 Posts
Default

Prolly a plugged main jet. Check that out and we'll go from there.
 
  #4  
Old 06-25-2019, 02:21 PM
Weekend Warrior
Thread Starter
Join Date: Jun 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default



I forgot to add. The guy I had bought it from said that there was a brand new carb installed on the bike. I can pull it off and clean it out anyways. And the other thing is there any way to tell if the exhaust is blocked off? When you start it you can feel good amount of flow through the exhaust
 
  #5  
Old 06-25-2019, 02:26 PM
Weekend Warrior
Thread Starter
Join Date: Jun 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Not sure if this gives any other ideas but this is a video of how it sounds
 
Attached Files
  #6  
Old 06-25-2019, 06:53 PM
Extreme Pro Rider
LT80 Expert
Join Date: Mar 2001
Posts: 7,951
Received 2 Likes on 2 Posts
Default

A new carb doesn't mean something didn't get in. Example: the tube on the right, that's the carb vent. I see it's pointing down. It is supposed to be run up under the hood. I don't know where it is going now, but that may well have how got dirt in. Also, in the pic you can see that the rubber piece/clamp that connects to the carb isn't 100% in the correct position.
Curious, have you done clutch maintenance?
 
  #7  
Old 06-25-2019, 11:09 PM
Weekend Warrior
Thread Starter
Join Date: Jun 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by LT80 View Post
Curious, have you done clutch maintenance?
this is going to sound terrible. But Iíve only owned it for 4 days! Havenít really wanted to go much farther then taking the carb off if itís something bad.im going to pull the carb tomorrow morning and clean it out. HOPEFUL that this will be the issue
 
  #8  
Old 06-26-2019, 01:24 PM
Weekend Warrior
Thread Starter
Join Date: Jun 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Cleaned out the carb this morning. Main jet was clean as a whistle. And the other jet had something small in it. Blew it out and reinstalled. Same exact problem. Itís got no ***** on the start. Then as it gets going it seems like it hits a rev limiter. Iím wondering if itís running out of fuel cause it starts smoking as it hits this ďrev limiterĒ ...very confused.. not sure if I should just return it to the seller haha
 
  #9  
Old 06-26-2019, 02:14 PM
Extreme Pro Rider
LT80 Expert
Join Date: Mar 2001
Posts: 7,951
Received 2 Likes on 2 Posts
Default

OK, back to the compression test.
I think the clutch's need maintenanced too. This is some of the star of trouble IMO.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
beyondupnorth
Kids Quads
9
10-19-2014 08:47 AM
rebuildlt80
Kids Quads
3
11-02-2009 06:32 AM
miniquadmom
Kids Quads
5
06-03-2004 12:04 AM
Mr45auto
Suzuki
2
04-19-2001 03:09 PM

Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 

Thread Tools
Search this Thread
Quick Reply: Suzuki LT80 - No Top End Power


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: