ATVConnection.com ATV Enthusiast Community

ATVConnection.com ATV Enthusiast Community (https://atvconnection.com/forums/)
-   Technical and How-To Articles (https://atvconnection.com/forums/technical-how-articles/)
-   -   ISSUES With 03 sportsman with low miles (https://atvconnection.com/forums/technical-how-articles/375093-issues-03-sportsman-low-miles.html)

hedgey 03-02-2018 08:49 PM

ISSUES With 03 sportsman with low miles
 
I have a hardly used sportsman that the fan has stopped working. Direct power turns fan on . The atv is now blowing antifreeze out and heating also some issues with fuel pump. I replaced fuel pump once .This has all happened about same time. Any ideas

old polaris tech 03-03-2018 05:35 AM

2 Attachment(s)
Most common problem on fans not kicking on was the fan sensor on radiator has burnt out. Item#21 in the parts break down. Plenty of cheaper aftermarket replacements for these now on amazon or ebay.https://www.ebay.com/itm/COOLING-RAD...JWLqDU&vxp=mtr Also because of the way the coolant return hose was routed back to the fill neck,bleeding all the trapped air in this model takes a little time.After the sensor is replaced,coolant installed,jack the front end up,tires off the ground a little and leave the radiator cap off. May take several times for the fan to cycle on and off for all the trapped air to be removed. Also there is one small bleed bolt on the water pump cover that you can open and close occasionally. You have to be patient on bleeding until the fan cycles on and off enough before the hot light comes on before the fan kicks does or it starts spewing coolant out of the over flow bottle.Once this is done you can top off the coolant,replace the cap and fill the over flow bottle. IF you're in a hurry you can get a Wells SW526 sensor from Autozone,etc and wire your old connector into it.


All times are GMT -5. The time now is 01:30 PM.


© 2018 MH Sub I, LLC dba Internet Brands