88 Yamaha 350 Warrior - ATVConnection.com ATV Enthusiast Community

Yamaha Discussions about Yamaha ATVs.
Sponsored by:
Sponsored by:

88 Yamaha 350 Warrior

  #1  
Old 03-16-2019, 12:40 PM
Weekend Warrior
Thread Starter
Join Date: Mar 2019
Posts: 2
Default 88 Yamaha 350 Warrior

I have a 1988 Yamaha 350 Warrior I was riding it run just fine came home one day parked it went out two days later to ride and it wouldn't run no more no spark so I put a new coil in it thinking that might be it it didn't happen still no spark so I bought a new stator put the new stator in and still no spark I've checked all the wiring I don't know where to turn can anybody help thank you
 
  #2  
Old 03-16-2019, 04:46 PM
Pro Rider
Join Date: Apr 2017
Posts: 226
Default

Could be a number of things. Check all of your grounds and kill switch first. check connections on everything bare wires. is the blue or orange wire hooked up good on the coil?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dynamodog
Yamaha
1
03-17-2019 04:07 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 88 Yamaha 350 Warrior


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: