Redcat 110 kazuma - ATVConnection.com ATV Enthusiast Community



Chinese Quads
Brands such as Jetmoto, Yamoto, Redcat, V-Bike, Hi Bird, and Kazuma

Reply
 
Thread Tools Search this Thread
  #1  
Old 07-29-2017, 07:28 PM
Weekend Warrior
Thread Starter
 
Join Date: Jul 2017
Posts: 4
Default Redcat 110 kazuma

i have a redcat 110 kazuma engine atv. Ran great carb leaked out the over flow. My kid blew the rings not shifting. I ordered new lower cylinder head with piston rings etc. and new upper cylinder head and new pz19 carb. I got parts in rookie the engine apart the plug was nice golden brown. Put all new parts on it started right up. It was smoking fuel smoke and wouldn't get out of its own way. Plug is jet black. I adjusted needle to be as low as possible fuel screw 1/4 turn out from seated still smokes and black plug. I put the old carb on. Same thing. Ordered another new carb I have not touched the screws on the 2nd new carb but still rich as can be however it does now have about 80% power it should have. Prior I could stand in front of bike holding it back and it would barely push and stumble. Now it reeves and breaks the tires loose. Stumped on what else to do. Also the first new carb I adjusted the float it would then run out of gas when you got on it but was still putting out fuel smoke and making the plug jet black even with fuel screw all way in needle all way down.
Reply With Quote
  #2  
Old 07-29-2017, 07:51 PM
Weekend Warrior
Thread Starter
 
Join Date: Jul 2017
Posts: 4
Default

Here is a video if it helps my camera didn't do very good job picking up the smoke.
Reply With Quote
  #3  
Old 07-31-2017, 03:57 PM
Weekend Warrior
Thread Starter
 
Join Date: Jul 2017
Posts: 4
Default Update

i figured out it was oil burning not rich from fuel. Tore it down and installed another new lower cylinder head and piston and rings. Now there is no more smoke. It will only start if you hit the throttle it fires right up sounds great sputters and dies after about a minute. I put my timing light on through the peep hole the F mark is showing 9 deg slow. My light has the advance timing feature 9 deg the f mark lines up dead on the mark in the peep hole. Any trick to advance the timing on these? The Magnito has no slots the pickup seems to have no slots as well while it's running has no real power if put it in gear.
Reply With Quote
  #4  
Old 07-31-2017, 06:20 PM
Weekend Warrior
Thread Starter
 
Join Date: Jul 2017
Posts: 4
Default Update

I had a pz 16 carb in the parts bin and put it on for kicks and atv runs perfect full power no smoke. Makes no sense the bike came stock with a 19. I bought 2 19's and would not run with ether one. Don't know how complete new top end would require a smaller carb but that solved the issue.
Reply With Quote
  #5  
Old 12-06-2017, 08:08 PM
Weekend Warrior
 
Join Date: Dec 2017
Posts: 1
Default Redcat wiring

I'm not sure how to post a question yet.
I have a red cat I replaced the harness on and am bot sure how to connect the stater wires.
please help
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: