Lt230 clutch actuator pinion shaft - ATVConnection.com ATV Enthusiast Community




Reply
 
Thread Tools Search this Thread
  #1  
Old 12-29-2016, 02:40 PM
Weekend Warrior
Thread Starter
 
Join Date: Dec 2016
Location: Ohio
Posts: 3
Default Lt230 clutch actuator pinion shaft

Hi all! New to the atv world and i have a few problem childs accumulated in the past month. Most recently i acquired a 1985 suzuki lt230 believe s the previous owner threw the chain and broke the case 2 years ago and let it sit. I replaced the case cover and torn entire bike apart to clean up and powder coat for my sons christmas gift. Put back together and fired up on 3rd kick. Not bad considering i have kick started anything in about 15 years and im new to the decompression thing. Ok so to the point when i took the clutch shaft out i just slide it straight up with a little resistance it came out i Didnt mean to pull shaft.... was trying to remove the arm itself. Well have the quad put back togather and it looks great and sounds great. But i have no spring back on the clutch lever. Meaning when i sqeeze the lever it just pulls the cable and it stays that way. Am i missing anything? There is not external spring. Stuck clutch pack? Please help i would love to see him riding it asap. Thanks all and be safe!
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:39 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send