Today's Tune - Page 3 - ATVConnection.com ATV Enthusiast Community

General Chat Ask for ATV help above in the Brand Discussions Area. Use this forum to discuss Life, Music, ETC. Or discuss pretty much anything BUT no political or religious threads. There's an area for that.

Today's Tune

  #21  
Old 09-01-2018, 07:39 PM
user493's Avatar
Moto Psycho
Join Date: May 2008
Location: Michigan
Posts: 8,747
  #22  
Old 09-02-2018, 11:59 PM
user493's Avatar
Moto Psycho
Join Date: May 2008
Location: Michigan
Posts: 8,747
  #23  
Old 09-02-2018, 11:59 PM
user493's Avatar
Moto Psycho
Join Date: May 2008
Location: Michigan
Posts: 8,747
  #24  
Old 09-03-2018, 12:00 AM
user493's Avatar
Moto Psycho
Join Date: May 2008
Location: Michigan
Posts: 8,747
  #25  
Old 09-03-2018, 12:04 AM
user493's Avatar
Moto Psycho
Join Date: May 2008
Location: Michigan
Posts: 8,747
  #26  
Old 09-04-2018, 03:49 PM
user493's Avatar
Moto Psycho
Join Date: May 2008
Location: Michigan
Posts: 8,747
Default

This has been playing in my head for a week. It's time to let it out. Gone Away, from The Offspring's 1997 album Ixnay on the Hombre.

 
  #27  
Old 09-04-2018, 03:51 PM
user493's Avatar
Moto Psycho
Join Date: May 2008
Location: Michigan
Posts: 8,747
Default

20 years later Five Finger Death Punch made their version of Gone Away.

 
  #28  
Old 09-07-2018, 12:50 AM
Big Frank's Avatar
Frank Flintstone
Join Date: Sep 2018
Location: Michigan
Posts: 552
Default

I finally got that song out of my head by listening to other songs by The Offspring among other things. The voice you may recognize on this second one is Larry "Bud" Melman (Calvert DeForest), who was on Late Night with David Letterman and Late Show with David Letterman from 1982-2002. He died in 2007. https://en.wikipedia.org/wiki/Calvert_DeForest




 
  #29  
Old 09-07-2018, 01:01 AM
Big Frank's Avatar
Frank Flintstone
Join Date: Sep 2018
Location: Michigan
Posts: 552
Default

Is anyone else having problems playing videos? I just get a message saying video unavailable in big letters on all 4 of those. If I right click, copy the URL, and paste it in another window, they all play at YouTube. I have no idea what I'm doing wrong. I copied and pasted the links just like I always have, and the videos show up here like they always have, but none of them work. Most of the other videos I posted lately do the same thing, but not all of them. One on this page says video unavailable in small letters but has the YouTube button on the bottom, and when I click it, the video plays on YouTube.
 
  #30  
Old 09-07-2018, 11:32 PM
Big Frank's Avatar
Frank Flintstone
Join Date: Sep 2018
Location: Michigan
Posts: 552
Default

I just tried playing every video on this page and they all said Video unavailable in big letters.
 

Thread Tools
Search this Thread
Quick Reply: Today's Tune


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: