Massimo - ATVConnection.com ATV Enthusiast Community



General RUV / UTV Discussion Discussions about Gators, Mules, Rangers, Rhinos and other off-road recreational vehicles.

Reply
 
Thread Tools Search this Thread
  #1  
Old 03-10-2017, 01:00 AM
Weekend Warrior
Thread Starter
 
Join Date: Jan 2017
Posts: 17
Default Massimo

New to this don't know if I'm on the right place to be. If I am forgive me. I have a Massimo side by side. It quit running all at one. The lights and all other things work but nothing to fuel pump and no fire to plug. Need help. Thank you. Gods blessings to all.
Reply With Quote
  #2  
Old 03-26-2017, 12:08 PM
Kymco 450i's Avatar
Pro Rider
 
Join Date: Jan 2016
Location: Perrysburg Ohio
Posts: 722
Default

Haven't seen a lot of postings about Massimo on this forum, however they do have their own forum if you care to search for it. I am sure the many Massimo owners on that site could give more insight to your problems. This forum is a great place with very helpful people on here, but not many Massimo people here just yet.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:30 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: