Starting problem - ATVConnection.com ATV Enthusiast Community

Introduce Yourself Just Joined? Be sure to pop in here and introduce yourself & let us know what you ride. PLEASE DO NOT ASK QUESTIONS FOR HELP IN THIS AREA. Your better off asking in the Brand Discussions Area.

Starting problem

  #1  
Old 12-04-2018, 11:25 PM
Weekend Warrior
Thread Starter
Join Date: Dec 2018
Posts: 3
Default Starting problem

I have a 300 ex Honda when I tried to start it the solenoid clicks I sent the starter to rebuilt got a new battery and a solenoid it still click does anybody kno how to solve this problem ??
 
  #2  
Old 12-05-2018, 06:39 AM
scootergptx's Avatar
Supersock
Hired Gun!
"Badges? We don't need no stinkin' badges!"
Join Date: Apr 2003
Location: 4th Floor, Footwear
Posts: 118,872
Default

Welcome to the forums.

Have you made sure it's got a good ground?
 
  #3  
Old 12-05-2018, 07:13 AM
Weekend Warrior
Thread Starter
Join Date: Dec 2018
Posts: 3
Default

Yes
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
wisconrincon
Honda
4
06-09-2006 12:34 AM
SnowDrift
Polaris
15
01-22-2005 01:22 PM
Yonkers
Yamaha
1
07-26-2000 06:58 PM
boris
Polaris
2
03-13-2000 07:30 PM
sandman_69_96_99
Performance Mods and Project Quads
1
01-20-2000 01:00 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Starting problem


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: