2005 VIPER 90R, loses power after it's warm.... - ATVConnection.com ATV Enthusiast Community



Kids Quads & Other ATV's - Ask an Expert! An area where experts in their field will answer non-general questions about your Chinese made ATV. mywifesquad, LT80, LynnEdwards and other experts will answer your questions as they have time.

Reply
 
Thread Tools Search this Thread
  #1  
Old 02-20-2017, 08:13 AM
Weekend Warrior
Thread Starter
 
Join Date: Feb 2017
Posts: 1
Default 2005 VIPER 90R, loses power after it's warm....

I bought a 2005 Eton 90R Viper for my daughter. I replaced the carb and fuel system due to the machine sitting for over 5 years prior to my purchase. I went through and cleaned everything out and it starts and runs pretty good. When she rides it will go fine for 15-20 minutes then it starts to lose power. However the engine seems to be running fine just the clutch seems to quit shifting. If you throw it in reverse it backs up and runs fine but going forward it won't hardly move itself on flat ground.... What should I look at in my clutches??
Reply With Quote
  #2  
Old 02-20-2017, 03:08 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 21,740
Default

Belt obviously,but the drive clutch sliders along with the rear centrifugal clutch may be what's wrong.Alpha Sports - E-Ton America Parts Catalog
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:27 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: