2008 Sportsman 500 ho efi problems - ATVConnection.com ATV Enthusiast Community

Go Back  ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Polaris
Reload this Page >

2008 Sportsman 500 ho efi problems

Polaris Discussions about Polaris ATVs.
Sponsored by:
Sponsored by:

2008 Sportsman 500 ho efi problems

  #1  
Old 02-05-2019, 09:31 AM
Weekend Warrior
Thread Starter
Join Date: Feb 2019
Location: NY
Posts: 2
Default 2008 Sportsman 500 ho efi problems

Hoping to get some help with my quad, it has been having on and off issues since I got it 4-5 years ago. Three codes have been stuck in this machine the whole time, it pulls codes 42, 47 and 58. I have tested the sensors and the IAC ohms out perfect, coolant temp sensor needs replacement as it is out of normal range and the cooling fan turns on and off while running the quad seemingly normal. I was plowing snow recently and the machine started to act up with lack of throttle response, changing idle between too high and too low and then finally it stalled. Check engine light flashed but there were no new codes, after the quad stalled it fired right back up. Any help will be greatly appreciated!
 
  #2  
Old 02-13-2019, 10:59 PM
Weekend Warrior
Thread Starter
Join Date: Feb 2019
Location: NY
Posts: 2
Default

Is there anyone that can help me out with this?
 
  #3  
Old 02-13-2019, 11:16 PM
Big Frank's Avatar
Frank Flintstone
Join Date: Sep 2018
Location: Michigan
Posts: 934
Default

I have no idea what's causing it but I wish I did. I have the same quad and will be waiting to see how you get it fixed in case I have that problem too at some point.
 
  #4  
Old 02-14-2019, 06:45 PM
Pro Rider
Join Date: Oct 2007
Location: Colorado
Posts: 830
Default

Since the ECM changes the fuel ratio for different engine conditions, I might recommend to replace your bad coolant temp sensor since you stated it is bad. If its giving the ECM a false reading, I think it might be safe to say that it may try to adjust the air/fuel using the idle air control motor. If the ecm doesnt get satisfied with what its getting from the inputs, maybe the IAC is reaching its "END' of travel and causing a code and light. I havent seen this personally, but it seems possible to me this "MAY" be a possible cause.

You have checked the wiring I assume. There have been numerous issues with wiring on polaris for years.

One other thing. I have seen engine codes that could NOT be cleared by removing the battery. I had a few that HAD to be cleared with digital wrench in the past. Wouldnt clear any other way.

I looked in Polaris' manual and it doesnt list a 58 code in the manual for that year. Not sure why.



 
  #5  
Old 02-14-2019, 11:21 PM
Big Frank's Avatar
Frank Flintstone
Join Date: Sep 2018
Location: Michigan
Posts: 934
Default

Page 55 of my owner's manual shows 2 things for blink code 58:
Fan Circuit: Open Load/Short-To-Ground.
Fan Circuit: Shorted Load/Short-To-Battery.
 
  #6  
Old 02-15-2019, 08:45 AM
Pro Rider
Join Date: Oct 2007
Location: Colorado
Posts: 830
Default

Originally Posted by Big Frank View Post
Page 55 of my owner's manual shows 2 things for blink code 58:
Fan Circuit: Open Load/Short-To-Ground.
Fan Circuit: Shorted Load/Short-To-Battery.
Cool. thanks. I wonder why the left it out of the service manual? Wierd.
 
  #7  
Old 02-15-2019, 03:56 PM
Big Frank's Avatar
Frank Flintstone
Join Date: Sep 2018
Location: Michigan
Posts: 934
Default

Originally Posted by 94harley View Post
Cool. thanks. I wonder why the left it out of the service manual? Wierd.
I haven't a clue. The owner's manual for one of my 500 H.O.s had the blink codes on a separate piece of paper. It already had blink codes in it but they added more and/or corrected what was already printed. Maybe they added a page to the service manual too.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rgjackson
General Chat
6
09-17-2015 11:21 AM
gearchick
Polaris
1
08-12-2014 09:03 AM
Sportsmanfanz
Polaris
2
05-24-2009 01:47 AM
Sportsmanfanz
Polaris
8
04-03-2009 03:41 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2008 Sportsman 500 ho efi problems


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: