Need Help - ATVConnection.com ATV Enthusiast Community



Technical and How-To Articles Post your Tech Tips and How-to articles here. Photo illustrations welcome

Reply
 
Thread Tools Search this Thread
  #1  
Old 08-29-2017, 06:57 PM
Weekend Warrior
Thread Starter
 
Join Date: Jul 2017
Posts: 6
Default Need Help

I have a 2005 John Deere Buck 650 4x4 and I'm reading that it's the same engine as the Quest. My bike's solenoid went out about 6 months ago and I just got around to changing it out. When I got it started I noticed there was an oil leak accompanied by a knocking noise. I fixed the oil sensor that was leaking but the knocking noise is still there. When I changed the oil I did notice metal shavings in the oil and on the oil filter. Any idea on what this could be or what I could be looking at to get it fixed? Any help is appreciated.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:14 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: