Prairie 360 4WD. light flashing - ATVConnection.com ATV Enthusiast Community


Go Back   ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Kawasaki
Search

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-22-2009, 04:29 AM
Weekend Warrior
 
Join Date: Feb 2009
Posts: 5
Default Prairie 360 4WD. light flashing

Today after about 3-4 hrs. of in and out of 4WD. Climbing, downhill, lots of low range, some splashing through puddles and some snow, at the end of all this, while in 2WD. the 4WD light started flashing 1/2 second on and 1/2 second off. Supposed to be the actuator.

I forgot to mention that it did this the last time I rode it and then, like now, when I shut the bike down for a short time and restarted, all was well. When the light was flashing, I had no 4WD.

The bike has 1000 km. on it and 110 hrs. of use.

Any ideas?

Thanks,
Pat
Reply With Quote
  #2  
Old 03-25-2009, 07:16 PM
Weekend Warrior
 
Join Date: Jun 2008
Posts: 6
Default Prairie 360 4WD. light flashing

looks like u need a new 4wd actuator dude
Reply With Quote
  #3  
Old 04-08-2009, 01:32 AM
Weekend Warrior
 
Join Date: Feb 2009
Posts: 5
Default It's not as scarey as I though

Howdy folks,
Did some checking by telephone and got some great advice from some long time Kawi wrenches. Seems that the 4WD light will flash if the engine brake actuator is giving problems as well and will fix it's self when you shut the ignition off and restart, which is what my bike is doing exactly.

Turns out that I do have 4WD when the light is flashing and it's either an engine brake actuator that's packing in or one that needs to be taken apart and cleaned. I was worried that I'd get way the heck back in the boonies and need 4WD to get home and it would pack in. Not the case at all, and that's a good thing.

Will let you know how the cleaning works out.

Pat
Reply With Quote
  #4  
Old 04-08-2009, 01:34 AM
Weekend Warrior
 
Join Date: Feb 2009
Posts: 5
Default It's not as scarey as I thought

Howdy folks,
Did some checking by telephone and got some great advice from some long time Kawi wrenches. Seems that the 4WD light will flash if the engine brake actuator is giving problems as well and will fix it's self when you shut the ignition off and restart, which is what my bike is doing exactly. Apparently the 4WD actuators either work or don't, they don't fix themselves like the engine brake actuators do.

Turns out that I do have 4WD when the light is flashing and it's either an engine brake actuator that's packing in or one that needs to be taken apart and cleaned. I was worried that I'd get way the heck back in the boonies and need 4WD to get home and it would pack in. Not the case at all, and that's a good thing.

Will let you know how the cleaning works out.

Pat
Reply With Quote
  #5  
Old 04-08-2009, 05:22 AM
Pro Rider
 
Join Date: Mar 2001
Posts: 211
Default

at 100hrs it flashes for a belt check. Just a safety thing. Could this be the reason? Check your manual.
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
New tires and LED light bar. MooseHenden Family ATVing Photos 5 09-20-2015 05:14 PM
2006 trx400FAGPS limp modem/ ESP wont shift vandammages@gmail.com Honda 2 09-13-2015 02:40 PM
1999 Polaris Sportsman 335 low top speed Steeldon Polaris ATVs - Ask an Expert! 4 09-09-2015 10:38 AM
Sportsman 400 Front wheel won't engage twon1235 Utility ATVs 2 09-07-2015 05:38 AM
Polaris Sportsman 335 low top speed Steeldon Utility ATVs 0 09-05-2015 10:38 PM


Tags
360, 4wd, 4x4, actuator, belt, blinking, brake, check, engine, flashing, kawasaki, kawaski, light, praire, prairie


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:21 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company