ATC 3-Wheelers Discussions on ATC 3-Wheelers.

Kawasaki KLT 160

  #1  
Old 10-08-2007, 09:44 PM
Weekend Warrior
Thread Starter
Join Date: Sep 2007
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Kawasaki KLT 160

This is my latest reclamation project. Over the last month I've been able to get two out of three 3 wheelers running again after several years of setting. The Kawasaki will be the hardest. Before this unit sat, I believe the timing chain jumped. I did get the chain back on, but now it will not fire. There is good spark, but the engine will not fire even using starting fluid. Could the timing be off so far that it will not fire? I even tried a little gas in the cylinder.

Thanks.
 
  #2  
Old 06-21-2018, 12:16 AM
Corey Rinebold's Avatar
Cheznut
Join Date: Jun 2018
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Help please!!

Iím having the same problem, I know this is an old post but did you or anyone figure this out?? Please help
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
wendal
Kawasaki
9
10-31-2017 03:31 AM
shimanok2
Buying an ATV
94
01-29-2016 07:37 PM
ReconBayou
Kawasaki
2
10-19-2015 02:06 AM
wendal
Suzuki
0
09-15-2015 01:50 PM
wendal
Buying an ATV
0
09-15-2015 01:48 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Kawasaki KLT 160


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: