02ish Yamaha warrior 350 clutch problems! - ATVConnection.com ATV Enthusiast Community

Go Back  ATVConnection.com ATV Enthusiast Community > ATV Community > General Chat
Reload this Page >

02ish Yamaha warrior 350 clutch problems!

General Chat Ask for ATV help above in the Brand Discussions Area. Use this forum to discuss Life, Music, ETC. Or discuss pretty much anything BUT no political or religious threads. There's an area for that.

02ish Yamaha warrior 350 clutch problems!

Reply

  #1  
Old 11-08-2018, 01:00 PM
B56
B56 is offline
Weekend Warrior
Thread Starter
Join Date: Nov 2018
Posts: 1
Default 02ish Yamaha warrior 350 clutch problems!

Hi guys, new to the forum here, and also new to the warrior.
I rebuilt a 350 engine for a friend after he disintegrated his cam chain and in turn crank bearings.
At this point I feel itís worth noting that the quad ran fine before this.
Iíve just sealed up the cases and got the engine back into the quad and now the clutch wonít engage, as soon as I pull in the clutch and put it into first itís just stalling, itís like Iím jamming it into gear. I took the clutch case off and set the little toothed drum properly to engage with the clutch hub itself, which should in turn push the clutch plates apart and allow it to start slipping, but still nothing. Iíve tried the cables, re torqued the clutch springs, checked the fibres and steels were all in order, still no luck. Anybody got any ideas?
Iíve read through the haynes manual countless times and find nothing, and checked the parts diagram to see if Iím missing anything and Iím not. Also the clutch basket isnít grooved but it does have a weld around the centre where the shaft comes through, told my friend to replace but heís a bit cheap. Also the clutch pack itself has play within the basket itself forward and back between the hub, maybe 25mm or so but all the parts are there, could this be the source of my troubles?
thanks for the help guys!
 
Reply With Quote
  #2  
Old 11-08-2018, 02:40 PM
Weekend Warrior
Join Date: Nov 2018
Posts: 5
Default

Hey B56, I'm new here too. I saw your post, and thought I'd chime in to advise you to post it in the Yamaha section. If you look at the top of general chat they say it's not the best place to post asking for tech advice etc. Hope this helps. All the best!
 
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
comininhot
Yamaha
4
03-31-2014 05:20 PM
Bhope9999
Technical and How-To Articles
1
03-25-2008 03:52 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 02ish Yamaha warrior 350 clutch problems!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: