2004 Polaris Magnun 330 flashing battery and speedo lights - ATVConnection.com ATV Enthusiast Community



Polaris Discussions about Polaris ATVs.

Reply
 
Thread Tools Search this Thread
  #1  
Old 01-21-2018, 11:02 AM
Weekend Warrior
Thread Starter
 
Join Date: Jan 2018
Posts: 5
Question 2004 Polaris Magnun 330 flashing battery and speedo lights

Tried to take it ice fishing, battery was dead. It's been going for a while so I replaced it with one from Menards.
new battery charged fine and it took a little to start due to it being 0 degrees out ! It seemed to run fine. I just went to use it again and the battery light is now flashing along with the speedo light.

I have read many forums before posting this but I could not find one exact even though I understand it lots more now !

Here is what I am getting with testing voltage:
Machine off: 12.8v
Running at idle: 14 to 15.8v
Running at higher rev: 16 to 18.3 ( this is when the flashing begins )

Please advise !
Reply With Quote
  #2  
Old 01-21-2018, 12:19 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 23,654
Default

Voltage way too high.Most cases it's another faulty ecm module but sometimes the stator could be the problem. Just a general check on the yellow wires leading to the ecm from the stator can usually eliminate it. There should be some small resistance between each yellow with no yellow shorting to ground. If you want to check further the 5 buck manual can help on this.2004 Polaris Magnum 330 Service Manual PDF Download If you narrow it down to a faulty ecm,check around on price as it can vary.Cheapest I've found on the 4010944 is a little over $200. Plus might be a good idea to charge the battery and have it load tested to see if it's still ok. Over charging can burn batteries up.
Attached Thumbnails
2004 Polaris Magnun 330 flashing battery and speedo lights-61wm4abt0tl._sl1500_.jpg   2004 Polaris Magnun 330 flashing battery and speedo lights-71f2y2i-pel._sl1500_.jpg  
Reply With Quote
  #3  
Old 01-21-2018, 01:20 PM
jumbofrank's Avatar
Moto Psycho
 
Join Date: May 2008
Location: Michigan
Posts: 7,944
Default

The voltage is way too high like OPT said. 18.3 volts is about 4 volts higher than it should be.
Reply With Quote
  #4  
Old 01-21-2018, 04:44 PM
Weekend Warrior
Thread Starter
 
Join Date: Jan 2018
Posts: 5
Default

Quote:
Originally Posted by old polaris tech View Post
Voltage way too high.Most cases it's another faulty ecm module but sometimes the stator could be the problem. Just a general check on the yellow wires leading to the ecm from the stator can usually eliminate it. There should be some small resistance between each yellow with no yellow shorting to ground. If you want to check further the 5 buck manual can help on this.2004 Polaris Magnum 330 Service Manual PDF Download If you narrow it down to a faulty ecm,check around on price as it can vary.Cheapest I've found on the 4010944 is a little over $200. Plus might be a good idea to charge the battery and have it load tested to see if it's still ok. Over charging can burn batteries up.
Thanks for your help, how do I test the resistance between each yellow?
Reply With Quote
  #5  
Old 01-21-2018, 05:03 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 23,654
Default

Reply With Quote
  #6  
Old 01-21-2018, 07:52 PM
Weekend Warrior
Thread Starter
 
Join Date: Jan 2018
Posts: 5
Default

Do I test that at the end of the stator plug near the regulator ? It that also near the ECM ?
Thanks for the links, I will be getting the manual too !!! Sorry for the basic questions, I just don't want to miss something !!!
Reply With Quote
  #7  
Old 01-21-2018, 08:06 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 23,654
Default

All you really have to do is check the resistance between the two yellow wires from the stator leading to the ecm.This can tell you rear quick in most cases if the stator is ok.Should be small resistance readings between each other and no yellow shorting to ground. Doing the ac output test is up to you if you want to go deeper as the manual shows if you want to down load it.Plus it can help you on other service and repairs.
Reply With Quote
  #8  
Old 01-27-2018, 12:11 PM
Weekend Warrior
Thread Starter
 
Join Date: Jan 2018
Posts: 5
Default

Okay, I checked the resistance between the yellow wires. Every way came back .6 to .8 so from what I read that sounds good. Is there anything I need to check on the regulator or does it all point to the ECM only ?
What typically makes the ECM go bad ?

The battery still checks 12.8v. How or where do I get it load tested ?

Thanks for all of your advice.
Reply With Quote
  #9  
Old 01-27-2018, 12:34 PM
old polaris tech's Avatar
Polaris ATV Expert
Retired and loving it!
 
Join Date: Jun 2008
Location: North Texas
Posts: 23,654
Default

Regulator/rectifier is an internal function of the ecm. Any auto store can load test a battery for you,but still points to a faulty ecm module since your resistance tests check out and charging was up to 18 volts.
Reply With Quote
  #10  
Old 02-03-2018, 07:37 AM
Weekend Warrior
Thread Starter
 
Join Date: Jan 2018
Posts: 5
Default

Old Polaris tech, thanks for all of your help.

I have the new ECM, I have not had time to get the battery load tested. If I install the new ECM am I taking a chance of having a issue with it without load testing my battery ? My batter only took that charge for a few seconds, never boiled over and did not swell up.

If it is not a good idea to go without load testing I will definitely get that done first, but if it's not going to hurt the new ECM I may swap it out and use it to get back out on the ice !!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 Polaris Sportsman 700 battery indicator flashing when fan kicks in and lights ar Stevei Polaris ATVs - Ask an Expert! 1 06-24-2017 10:44 AM
2002 Polaris Sportsman 700 battery flashing when turn lights on and fan engages Stevei Polaris 1 06-24-2017 10:39 AM
Statr light flashing and wrench flashing 2003 600twin Big600twin Polaris 4 11-02-2016 11:16 AM
Spindle Help 02 magnun 325 4*4 robinsoss Polaris 4 02-17-2010 12:49 AM
2005 Battery Symbol & Guage Cluster Lights Flashing?? behindredeyes Polaris 6 03-07-2007 12:16 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:26 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: