2004 Polaris Ranger won't run with air cleaner cover on - ATVConnection.com ATV Enthusiast Community

Go Back  ATVConnection.com ATV Enthusiast Community > General Discussion > Technical and How-To Articles
Reload this Page >

2004 Polaris Ranger won't run with air cleaner cover on

Technical and How-To Articles Post your Tech Tips and How-to articles here. Photo illustrations welcome

2004 Polaris Ranger won't run with air cleaner cover on

  #1  
Old 10-14-2018, 12:45 PM
Weekend Warrior
Thread Starter
Join Date: Oct 2018
Posts: 1
Default 2004 Polaris Ranger won't run with air cleaner cover on

I am looking for some help
I have a 2004 500 Ranger, when I brought it home it ran good. When I took it out on the road it started to back fire and miss after about an hour.
I got it back to the shop pulled the air filter out, made sure it was clean, replaced the spark plug and gas filter. started it up and ran ok. about an hour later it started to back fire and miss then it died. would not start. took the air filter cover off and tried to start it and it ran until I went to 1/2 throttle then it started to spit and sputter. pulled the choke out and it cleared up until i took it to 3/4 throttle. I have rebuilt the carb, I have checked the timing and the cam lobs I have replaced the electric fuel pump.
I tried a different known good carb. I even took the drive belt off to make sure the transmission did not have something to do with it. It appears to be starving itself for fuel but what else am I missing? the intake between the carb and head is good (sprayed down with carb cleaner and no difference with RPM's)
After all of the things I have tried I can run up and down the road if I play with the choke and not go above 3/4 throttle and do not have the air filter cover on the air filter housing, Yes the air filter is installed just have to remove the cover for the air filter box.
 
  #2  
Old 02-10-2019, 05:14 PM
Weekend Warrior
Join Date: Aug 2018
Location: Oklahoma
Posts: 5
Default

My 2008 sportsman 500 ho was doing close to the same thing. I cleaned carb even out and didnít make a difference if I put my hand over the intake tube I could get it to rev up for a second or two. I ended up replacing carb and fuel pump and my ran like the day I bought it.
 
  #3  
Old 02-11-2019, 02:02 AM
Big Frank's Avatar
Frank Flintstone
Join Date: Sep 2018
Location: Michigan
Posts: 712
Default

How's the spark plug look?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
budmantom
Honda
19
12-10-2006 02:40 PM
Speedy2222
Yamaha
2
10-15-2006 12:27 AM
LTZ400guy
Yamaha
6
11-02-2005 08:01 PM
WVeiger
Suzuki
1
08-10-2005 09:37 AM
spencer
Performance Mods and Project Quads
1
07-05-2000 05:49 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2004 Polaris Ranger won't run with air cleaner cover on


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: