Warrior 350 sputtering and popping - ATVConnection.com ATV Enthusiast Community

Go Back  ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Yamaha
Reload this Page >

Warrior 350 sputtering and popping

Yamaha Discussions about Yamaha ATVs.

Warrior 350 sputtering and popping

Reply

  #1  
Old 06-13-2018, 04:57 PM
Weekend Warrior
Thread Starter
Join Date: Jun 2018
Posts: 1
Default Warrior 350 sputtering and popping

My 2001 warrior 350 has been sputtering and popping at high rpms. I changed the plugs. I am pretty sure it is jetting but the person i got it off of didn't know anything as he was selling it for a friend. Anyone know what the problem could be? just cleaned the carb a few weeks ago. it also has a aftermarket filter
 
Reply With Quote
  #2  
Old 06-14-2018, 06:30 AM
Range Rover
Join Date: Apr 2017
Posts: 158
Default

do a plug chop that will tell you if it is jetting. Ive also had them do that and it was a weak stator. Also a bad carb boot could cause it.
 
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RABDAB
Yamaha
0
12-07-2009 08:11 AM
jaymarti
Yamaha
4
12-06-2005 06:02 PM
swampman
Yamaha
2
11-06-2005 01:35 PM
SuzukiRiderz400
Suzuki
4
05-28-2005 09:37 PM
Fast5Ty
Yamaha
9
03-10-2005 09:13 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Warrior 350 sputtering and popping


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: