Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Suzuki
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply
  #1  
Old 12-07-2007, 05:08 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Dec 2007
Posts: 2
Default 2006 LT50 problems

Ok, I need some help. I bought my daughter a new 2006 LT50 quad. Within 4 hrs run time, the CDI went out. I bought a new one only to find that there was an aftermarket one the got rid of the rev limiter. Oops! Just this last Thanksgiving weekend, we took a trip to Glamis. The bike started and ran, but once the throttle was pushed, it died. I went through everything. Drained the gas, cleaned the carb and put in a new plug-nothing. There are two things that I am confused about. When it is first started in the morning, it will run for about 50 ft them die. Also, the air box was filled with motor oil. Not too sure why. CAN ANYONE HELP ME GET MY DAUGHTER RIDING AGAIN? Thanks.
Reply With Quote
  #2  
Old 12-07-2007, 08:14 PM
Pro Rider
Garage is empty, add now
 
Join Date: Jul 2007
Posts: 208
Default 2006 LT50 problems

I left you a reply in the kids quad forum
Reply With Quote
Old 12-07-2007, 08:14 PM
Reply

Tags
06, 2006, 50, cdi, limiter, lt, lt50, motor, problem, problems, rev, suzuki



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On