My account - ATVConnection.com ATV Enthusiast Community



Chinese Quads
Brands such as Jetmoto, Yamoto, Redcat, V-Bike, Hi Bird, and Kazuma

Reply
 
Thread Tools Search this Thread
  #1  
Old 05-18-2017, 07:08 PM
Weekend Warrior
Thread Starter
 
Join Date: May 2017
Posts: 2
Default My account

I bought my son a 49cc Chinese quad its automatic with only electric start it ran for a bit then died. All it does now is click. New solenoid and battery. When I jump the solenoid it don't do anything. Does anyone know what could be the issue.
Reply With Quote
  #2  
Old 05-19-2017, 02:14 AM
Pro Rider
 
Join Date: Oct 2013
Location: Lancaster England
Posts: 2,326
Default

Almost certain to be the starter. My standard test:- Get a 12v test lamp, connect one lead to earth, the other to the starter lead that runs between solenoid and starter motor. Switch on, press starter button, if the lamp lights but the starter doesn't turn, your starter needs work. Just possible the whole engine is seized, but you can check if the engine turns after you get the starter off.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:27 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: