Honda Discussions about Honda ATVs.
Sponsored by:
Sponsored by:

Rancher 06 400trx drive issue

  #1  
Old 12-30-2018, 12:09 AM
Weekend Warrior
Thread Starter
Join Date: Dec 2018
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Rancher 06 400trx drive issue

I'm new to the site and could really use some help. My screen will not show the gears in drive. It would do it occasionally when riding and now it will not show them at all. It will still move forward but just doesn't show the gears and won't allow me to shift. It does that in both drive posessions. Neutral and reverse both show on the screen. I replaced the angle sensor and I did preload it. I reset it how the manual said to and it worked properly just didn't fix my problem.
 
  #2  
Old 12-30-2018, 03:34 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,805
Likes: 0
Received 0 Likes on 0 Posts
Default

I'm a bit puzzled, as don't you just get a D when in auto on a 400? The 1 to 5 is only when in ESP. You should be getting a blinking -- instead which is the fault code in Morse. Does it change gear when in auto?
 
  #3  
Old 12-30-2018, 12:54 PM
Weekend Warrior
Thread Starter
Join Date: Dec 2018
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for the reply .I'm not getting any flashes like before. I was getting six flashes now when I put it in drive on either position all I get is -- .Not sure what to do with without a code.
 
  #4  
Old 12-31-2018, 03:09 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,805
Likes: 0
Received 0 Likes on 0 Posts
Default

All you can do is check the whole gearbox wiring system for shorts and bad connections. Then I would probably take it to the dealer, a good one will be able to tell if it needs a new ECU. If it does, it is going to be expensive, though there was a recall on the 400 ECU, if the dealer kept the ones they took off, you may get one as a cheap replacement, but these recalled ECUs may go wrong, which is why they were removed in the first place.
 
  #5  
Old 12-31-2018, 07:17 AM
Weekend Warrior
Thread Starter
Join Date: Dec 2018
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by merryman View Post
All you can do is check the whole gearbox wiring system for shorts and bad connections. Then I would probably take it to the dealer, a good one will be able to tell if it needs a new ECU. If it does, it is going to be expensive, though there was a recall on the 400 ECU, if the dealer kept the ones they took off, you may get one as a cheap replacement, but these recalled ECUs may go wrong, which is why they were removed in the first place.
Thanks for the info. Really appreciate it
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Christopher Pollack
Honda
0
07-25-2017 07:55 AM
vio
General Chat
0
06-15-2017 12:00 PM
captaininstructo
Honda
3
01-07-2017 08:03 AM
Rudnik
Buying an ATV
6
05-03-2000 11:05 PM
GreggWNY
Polaris
8
08-22-1999 02:29 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Rancher 06 400trx drive issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: