Smoking Mule - ATVConnection.com ATV Enthusiast Community



Reply
 
Thread Tools Search this Thread
  #1  
Old 11-30-2014, 05:36 PM
Pro Rider
Thread Starter
 
Join Date: May 2004
Posts: 587
Default Smoking Mule

I have a Mule 610 that only has 22 hrs, I took it to a dealer to get it serviced...they said I needed a fuel pump,as well....When you first start it,and let it idle for about 15 minutes to warm up its just fine... but when you start heading out and push the pedal it starts smoking white....after you shut it down and restart it it doesn't smoke until you move out and start pushing the pedal??? Do think it may be a broken oil ring?...it takes a while to heat up before it starts the white stuff??? Help!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 sportsman700 blowing coolant out of overflow after riding hard jrooker6 Polaris 18 04-23-2016 07:36 PM
2010 Tao Tao 110D Electrickery EIF Chinese Quads 0 09-25-2015 06:59 PM
2001 Breeze 125 smoking top end CosmoM Yamaha 0 09-21-2015 04:57 PM
2004 kfx 400 xreynolds95 Technical and How-To Articles 3 09-21-2015 04:51 AM
Sudden blowby and hard starting bvolks Kawasaki 8 09-13-2015 12:57 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:03 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send