Kawasaki Discussions about Kawasaki ATVs.

Kawasaki Brute Force 300 Shutting Down

  #1  
Old 05-16-2019, 09:38 PM
Weekend Warrior
Thread Starter
Join Date: May 2019
Posts: 1
Default Kawasaki Brute Force 300 Shutting Down

We purchased a 2012 Brute Force 300 a few days ago. It's in excellent condition and hardly a scratch. No gravel pits or paint missing underneath. It all went great for a couple days and then my boys started complaining it is shutting off. It's only when they run it a mile or two. It's like its heating up and shutting down. The radiator is very clean. The fans are working, they kick on when it warms up. Is there a safety on these that shuts them off when they get hot? What might be the problem? Thank you
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jonsie
Polaris
6
08-04-2006 05:50 PM
wolffman
Suzuki
9
06-29-2006 10:16 PM
sahzookee
Suzuki
9
05-08-2006 05:11 AM
DEPALMA
Where to Ride
14
04-16-2005 03:22 AM
BudO
Kawasaki
4
06-04-2004 05:52 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Kawasaki Brute Force 300 Shutting Down


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: