lt80 rear clutch issue - ATVConnection.com ATV Enthusiast Community

Kids Quads Discussions about Kid's Quads and other ATV's.

lt80 rear clutch issue

  #1  
Old 03-27-2007, 01:18 AM
Trailblazer
Thread Starter
Join Date: Feb 2004
Posts: 89
Default lt80 rear clutch issue

What would cause the rear clutch drum to get all grooved up on the inside? I'm assuming the clutch pads are coming into contact with it severely. I'm assuming that they shouldn't make contact at all, or am I wrong? I'm still learning about these CVT's and how they work. I have a complete Moore modded engine. But now our holeshots are going sour again. When Cody was on the brake before and brought the RPM's up for the start that thing would flat out launch. Now the RPM's don't come up near as much and it "rolls" 10 feet before getting off it's ***. Could it possibly be worn out springs on the clutch pads?

Any help is appreciated!

Thanks
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
KimSJoh
Polaris Ask an Expert! In fond memory of Old Polaris Tech.
14
07-18-2015 08:20 PM
coolguy420
General Chat
2
07-10-2015 02:17 AM
traumajunkie
Suzuki
1
07-05-2015 04:03 PM
J-Mack
Polaris Side by Sides
3
07-04-2015 05:19 PM
Other Makes
0
06-20-2015 04:19 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: lt80 rear clutch issue


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: