Polaris Discussions about Polaris ATVs.
Sponsored by:
Sponsored by:

battery icon on display

  #1  
Old 07-09-2019, 03:09 PM
Weekend Warrior
Thread Starter
Join Date: Jul 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default battery icon on display

My 400 sportsman will not start and after a few seconds displays a blinking battery icon on the display, the battery is fully charged. Please help. Thanks in advance
 
  #2  
Old 07-10-2019, 05:24 PM
Kymco 450i's Avatar
Pro Rider
Join Date: Jan 2016
Location: Perrysburg Ohio
Posts: 1,740
Likes: 0
Received 1 Like on 1 Post
Default

Load test the battery as it could have an internal short. Have seen this a number of times. Also check connections, loose or corroded connections will cause same issues. Good luck. Last resort, try another battery.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dmach8
Polaris
5
09-02-2009 07:30 PM
PolarisWacko
Polaris
3
02-15-2007 09:31 PM
superintendent
Polaris
5
12-31-2006 06:21 PM
Fletchman
Polaris
2
06-18-2004 04:13 PM
BigKid
Polaris
1
08-01-2003 11:27 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: battery icon on display


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: