hard to start after carb rebuild - ATVConnection.com ATV Enthusiast Community



Suzuki Discussions about Suzuki ATVs.

Reply
 
Thread Tools Search this Thread
  #1  
Old 02-21-2017, 06:53 PM
weekend warrior
Thread Starter
 
Join Date: Feb 2017
Location: keene,nh
Posts: 23
Default hard to start after carb rebuild

it was starting pretty good but half throttle was a little crapy so i had someone rebuild the carb ,but now it won,t try to start unless i put a heat gun on the head for a few minuts,then it starts right up and runs good,in the summer i had no trouble
only since it got cold out.any ideas anyone????????? help please
this is a 1992 suzuki king quad 300 about 1800 miles on it
Reply With Quote
  #2  
Old 02-22-2017, 02:56 AM
Pro Rider
 
Join Date: Oct 2013
Location: Lancaster England
Posts: 2,088
Default

Seems like the rebuilder has done something wrong. Most obvious, does the choke work? It could be compression, it is worth checking, anything over 90psi is OK, if it is low, re-set the valve clearances and check again. If compression is good, clean the carb again, just hope the re-builder didn't fit parts wrongly, or the wrong parts.

Just a thought, fit a new plug first, surprising how often this is a magic cure.
Reply With Quote
  #3  
Old 03-21-2017, 10:28 PM
Weekend Warrior
 
Join Date: Mar 2017
Posts: 16
Default

Check to be sure choke is closing all the way. If Its getting stuck partially open it will do the same thing.
Reply With Quote
  #4  
Old 03-22-2017, 08:47 AM
DirtDevil101's Avatar
Pro Rider
 
Join Date: Oct 2015
Posts: 776
Default

Sounds like your choke isn't working and not dumping enough fuel into the mixture on cold start...
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:50 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: