2000 Suzuki LT80 Quadbike doesn't work - ATVConnection.com ATV Enthusiast Community

Go Back  ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Suzuki
Reload this Page >

2000 Suzuki LT80 Quadbike doesn't work

Suzuki Discussions about Suzuki ATVs.

2000 Suzuki LT80 Quadbike doesn't work

Reply

  #1  
Old 11-07-2018, 12:49 AM
Weekend Warrior
Thread Starter
Join Date: Oct 2018
Posts: 3
Default 2000 Suzuki LT80 Quadbike doesn't work

Hi, I have owned my quad for around 5/6 years now and its mainly just sat around not being used as Ive had no where to drive it. I fixed it myself last year as it was having problems and wouldn't start. Bought a brand new battery and new spark plug also replaced the fuzes, got it started then later on in the day i was driving close to full speed and the quad just stopped working. It now has been sitting for probably another 8-12 Months without anything being done to it since, since replacing the sparks and battery I haven't tried to fix the problem since, I have taken the whole bike apart to find the route of the problem but never got around to taking it anywhere. Any Help would be great just want to be riding it again. Any Suggestions will be great can provide audio/video/pictures of anything requested. Thanks Heaps!

####UPDATE####
Have found the key and have been trying to start it and there is a small black box - around the same size and looks as where the fuzes go so unaware of whats going on, the box is openable but im not to sure if i will break it opening it! thanks
 
Reply With Quote
  #2  
Old 11-07-2018, 09:29 AM
Extreme Pro Rider
LT80 Expert
Join Date: Mar 2001
Posts: 7,747
Default

Do a compression test. Clean the carb. Is the plug wet from trying to start? Does it have spark?
 
Reply With Quote
  #3  
Old 11-07-2018, 04:50 PM
Weekend Warrior
Thread Starter
Join Date: Oct 2018
Posts: 3
Default

Hi, Iím not to sure how I would go about doing a compression test or carb cleaning. I can get to the spark plug but I will have to take the plastics off the bike. Iíve been told that the starter relay is broken as it just makes a clicking noise when I try to start it, I cleaned the current one I have and have given my battery a full charge but still nothing.
 
Reply With Quote
  #4  
Old 11-09-2018, 04:21 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,354
Default

A 2000 model LT80 will have a trip switch under the RH rear wheelarch. If the starter is overloaded the switch trips out and you have to press a button on it to re-set it. Reasons for tripping vary, but a common one is for the tap to be left on PRIME, fuel then leaks past the carb float needle causing the cylinder to be full of fuel, hydraulic locking it. You don't need the plastics off for plug removal, but carb removal is a PITA.
 
Reply With Quote
  #5  
Old 11-09-2018, 09:02 AM
Extreme Pro Rider
LT80 Expert
Join Date: Mar 2001
Posts: 7,747
Default

"but carb removal is a PITA." lol
 
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mrstangblb
Polaris Ask an Expert! In fond memory of Old Polaris Tech.
46
03-28-2017 11:49 PM
410Customs
Suzuki
96
01-24-2017 10:18 AM
ByUCajun
Kawasaki
3
04-15-2002 01:41 PM
DuneJammer
CAN-AM (BRP)
5
05-21-2001 01:06 AM
Teamtraxxx
Honda
0
05-16-2000 02:07 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2000 Suzuki LT80 Quadbike doesn't work


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: