2003 LT80 won't run when brake switch released - ATVConnection.com ATV Enthusiast Community

Go Back  ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Suzuki
Reload this Page >

2003 LT80 won't run when brake switch released

Suzuki Discussions about Suzuki ATVs.

2003 LT80 won't run when brake switch released

  #1  
Old 01-14-2019, 05:54 PM
Weekend Warrior
Thread Starter
Join Date: Dec 2018
Posts: 3
Default 2003 LT80 won't run when brake switch released

My 2003 LT80 will not run after the brake switch is released. I start the bike and when I release the brake switch, the bike quits. The bike will not restart unless the brake pedal switch is engaged again.

The brake switch has been replaced with a new Suzuki switch and the wiring harness has been checked for any faults.

Any ideas on why the bike won't run when the brake switch is released? What else should I check or replace?
 
  #2  
Old 01-14-2019, 07:45 PM
Extreme Pro Rider
LT80 Expert
Join Date: Mar 2001
Posts: 7,879
Default

Prolly a bad frame to motor ground.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
delanyc
Suzuki
2
12-22-2018 09:46 AM
mcordani
Other ATV Topics
4
08-01-2012 04:40 PM
ronnieb8406
Yamaha
1
10-15-2009 12:24 PM
trx430ex
Honda
1
06-07-2000 11:49 AM
Jamie
Polaris
8
04-06-2000 02:09 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 2003 LT80 won't run when brake switch released


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: