ltz400 only idles - ATVConnection.com ATV Enthusiast Community

Suzuki Discussions about Suzuki ATVs.

ltz400 only idles

  #1  
Old 03-09-2019, 05:15 PM
Weekend Warrior
Thread Starter
Join Date: Jul 2007
Posts: 6
Default ltz400 only idles

lets beat a dead horse...but have not found the fix!

yes i have fuel
yes i cleaned the carb
yes i have spark with a new plug
yes the float is working
yes the brake has been bypassed
yes all the hoses are connected
yes the airfilter is good and clean
yes its fresh fuel

i dont understand...i ran it with fresh fuel..idles fine...will rev up fine and rode fine...put it back into a heated pole barn and now will start fine but wont rev up at all no matter what i do...and i have searched for an answer and im at a loss

any help would be great thanks!
 
  #2  
Old 03-09-2019, 09:30 PM
Weekend Warrior
Join Date: Mar 2019
Posts: 4
Default

Sounds like its getting flooded ik you cleaned the carb but make sure the float needle is doing its job!
 
  #3  
Old 03-10-2019, 01:04 PM
Weekend Warrior
Thread Starter
Join Date: Jul 2007
Posts: 6
Default

Originally Posted by Drewberger88 View Post
Sounds like its getting flooded ik you cleaned the carb but make sure the float needle is doing its job!
think that it would come out the overflow?
 
  #4  
Old 03-10-2019, 06:45 PM
scootergptx's Avatar
Supersock
Hired Gun!
"Badges? We don't need no stinkin' badges!"
Join Date: Apr 2003
Location: 4th Floor, Footwear
Posts: 118,896
Default

Not knowing the year model, is the petcock set to on or prime? Throttle cable looks to be working ok?
 
  #5  
Old 03-14-2019, 06:01 PM
Weekend Warrior
Thread Starter
Join Date: Jul 2007
Posts: 6
Default

Originally Posted by scootergptx View Post
Not knowing the year model, is the petcock set to on or prime? Throttle cable looks to be working ok?
yeah all ok
2003 ltz400
i think the ignition is cutting out but not sure why
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aaron7
Polaris
3
01-21-2017 09:02 AM
DuHaas
Suzuki
0
12-05-2010 03:08 PM
stebob
Polaris
0
08-02-2010 10:56 AM
Simple Man
CAN-AM (BRP) Ask an Expert!
2
01-08-2010 01:38 AM
jimjet
Yamaha
4
12-05-2007 04:01 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: ltz400 only idles


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: