Suzuki Discussions about Suzuki ATVs.

Help I have no clue what's wrong with my quad

  #1  
Old 03-10-2019, 07:07 PM
Weekend Warrior
Thread Starter
Join Date: Mar 2019
Posts: 1
Default Help I have no clue what's wrong with my quad

Ok so I have a older lt160 quad and my battery was dead and I needed to start it, so naturally I bump started it and it made a nasty noise and now none of my gears work and when in gear the wheels move but the engine does not. I assume it is a bad clutch but I'm new to atv maintenance so I want some help before I order any parts.
 
  #2  
Old 03-11-2019, 03:53 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,727
Default

Not a good idea to bump start quads. Do not order anything until you find out what is wrong. Try adjusting the clutch, you never know your luck, but if that doesn't work, take the cover off and find out if it is one of the clutches that has gone. It may be a transmission fault, I don't know the LT160, but can the chain hop off the engine sprocket?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BAYOUMASTER
Yamaha
0
01-31-2005 07:16 PM
Raptorboy4life
Yamaha
11
03-14-2004 12:02 AM
Speedy2222
Where to Ride
12
07-31-2003 06:49 PM
POLARISFREAK
Polaris
2
06-17-2003 08:06 PM
RacinJason
CAN-AM (BRP)
3
04-29-2003 05:04 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Help I have no clue what's wrong with my quad


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: